Bug 1990368 - python-btrfs: FTBFS in Fedora rawhide
Summary: python-btrfs: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-btrfs
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juan Orti
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: PYTHON3.10 F35FTBFS F36FTBFS
TreeView+ depends on / blocked
 
Reported: 2021-08-05 09:34 UTC by Tomáš Hrnčiar
Modified: 2021-09-01 09:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-01 09:11:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github knorrie python-btrfs issues 31 0 None None None 2021-08-06 13:38:08 UTC

Description Tomáš Hrnčiar 2021-08-05 09:34:16 UTC
Description of problem:
Package python-btrfs fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
13-3.fc35

Steps to Reproduce:
koji build --scratch f35 python-btrfs-13-3.fc35.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-btrfs

This looks like an error caused by the latest version of Sphinx.

Exception occurred:
  File "/usr/lib/python3.10/site-packages/sphinx/util/docfields.py", line 369, in transform
    new_list += fieldtype.make_field(fieldtypes, self.directive.domain, items,
TypeError: patched_make_field() got an unexpected keyword argument 'inliner'

Comment 1 Ben Cotton 2021-08-10 13:35:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 2 Fedora Release Engineering 2021-08-22 04:27:53 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-09-30).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 3 Juan Orti 2021-09-01 09:11:48 UTC
Upstream has added a patch to fix this issue when sphinx version is >= 4

This now builds successfully in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=74910269


Note You need to log in before you can comment on or make changes to this bug.