Bug 199038 - calc: file->export->crash
calc: file->export->crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: Reopened
: 199400 (view as bug list)
Depends On:
Blocks: FC6Target FC6Desktop
  Show dependency treegraph
 
Reported: 2006-07-16 05:53 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 16:23:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2006-07-16 05:53:05 EDT
0x457ad2a8: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x3ad2a8
(sfx2::FileDialogHelper_Impl::execute(SvStringsDtor*&, SfxItemSet*&, String&) +
0x198)
0x457ae24d: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x3ae24d
(sfx2::FileDialogHelper::Execute(SfxItemSet*&, String&) + 0x1d)
0x456ee415: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x2ee415
(ModelData_Impl::OutputFileDialog(signed char, comphelper::SequenceAsHashMap
const&, unsigned char, rtl::OUString&) + 0x1035)
0x456f1af6: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x2f1af6
(SfxStoringHelper::GUIStoreModel(com::sun::star::uno::Reference<com::sun::star::frame::XModel>
const&, rtl::OUString const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&) + 0x5a6)
0x45697c6d: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x297c6d
(SfxObjectShell::ExecFile_Impl(SfxRequest&) + 0x170d)
0x457459e7: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x3459e7
(SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char)
+ 0x237)
0x4573a924: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x33a924
(SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*, SfxShell*) + 0x74)
0x4576280a: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x36280a
(SfxDispatchController_Impl::dispatch(com::sun::star::util::URL const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&,
com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener>
const&) + 0x113a)
0x45763199: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x363199
(SfxOfficeDispatch::dispatch(com::sun::star::util::URL const&,
com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 0x149)
0x49741464: /usr/lib64/openoffice.org2.0/program/libfwk680lx.so + 0x141464
0x41081016: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x281016
(Menu::Select() + 0x36)
0x4107cb65: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x27cb65
(Menu::ImplCallSelect(Menu*) + 0x15)
0x410dd891: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x2dd891
(ImplWindowFrameProc(void*, SalFrame*, unsigned short, void const*) + 0x701)
0xaee22b36: /usr/lib64/openoffice.org2.0/program/libvclplug_gen680lx.so +
0x68b36 (SalDisplay::DispatchInternalEvent() + 0xb6)
0xae96af89: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so +
0x1ff89 (GtkXLib::userEventFn(void*) + 0xa9)
0x3602cf64: /lib64/libglib-2.0.so.0 + 0x2cf64 (g_main_context_dispatch + 0x1b4)
0x3602fdad: /lib64/libglib-2.0.so.0 + 0x2fdad
0x360302de: /lib64/libglib-2.0.so.0 + 0x302de (g_main_context_iteration + 0x6e)
0xae96b448: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so +
0x20448 (GtkXLib::Yield(unsigned char) + 0xb8)
0x40f24ff4: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x124ff4
(Application::Yield() + 0x44)
0x40f25075: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x125075
(Application::Execute() + 0x25)
0x49230f62: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x30f62
(desktop::Desktop::Main() + 0x1492)
0x40f2a183: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x12a183
(ImplSVMain() + 0xe3)
0x40f2a275: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x12a275
(SVMain() + 0x25)
0x4922456e: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x2456e
(sal_main + 0x3e)
0x34420aa4: /lib64/libc.so.6 + 0x20aa4 (__libc_start_main + 0xf4)
0x400619: /usr/lib64/openoffice.org2.0/program/scalc.bin + 0x619
Comment 1 Nicolas Mailhot 2006-07-16 05:55:53 EDT
Calc crashed when I asked it to export a range of cells

openoffice.org-calc-2.0.3.x86_64
openoffice.org-core-2.0.3.x86_64
openoffice.org-draw-2.0.3.x86_64
openoffice.org-graphicfilter-2.0.3.x86_64
openoffice.org-impress-2.0.3.x86_64
openoffice.org-langpack-es-2.0.3.x86_64
openoffice.org-langpack-fr-2.0.3.x86_64
openoffice.org-langpack-ru-2.0.3.x86_64
openoffice.org-math-2.0.3.x86_64
openoffice.org-writer-2.0.3.x86_64
openoffice.org-xsltfilter-2.0.3.x86_64
Comment 2 Nicolas Mailhot 2006-07-16 06:45:50 EDT
glib2-2.12.0.i386
glib2-2.12.0.x86_64

gtk2-2.10.0.i386
gtk2-2.10.0.x86_64

maybe a dupe of bug #199039
Comment 3 Caolan McNamara 2006-07-17 04:35:13 EDT
we might have the right fix for this checked in, until OOo is buildable with the
new gcc though I'm kind of blocked in getting any fixes out the door
Comment 4 Caolan McNamara 2006-07-17 10:17:44 EDT
caolanm->mclasen: file->export works fine on x86_64 with 

gtk2-2.10.0-1

but crashes with

gtk2-2.10.0-2 and gtk2-2.10.0-3
Comment 5 Caolan McNamara 2006-07-18 09:46:50 EDT
First the spew on output

(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri !=
NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_ref: assertion `uri !=
NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **:
gnome_vfs_get_file_info_uri_cancellable: assertion `uri != NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri
!= NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri
!= NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_to_string: assertion
`uri != NULL' failed
(scalc.bin:3518): libgnomevfs-CRITICAL **: gnome_vfs_uri_unref: assertion `uri
!= NULL' failed
(scalc.bin:3518): Gtk-CRITICAL **: gtk_list_store_get_value: assertion
`VALID_ITER (iter, list_store)' failed
(scalc.bin:3518): GLib-GObject-WARNING **: gtype.c:3337: type id `0' is invalid
(scalc.bin:3518): GLib-GObject-WARNING **: can't peek value table for type
`<invalid>' which is not currently referenced
Comment 6 Caolan McNamara 2006-07-18 09:47:27 EDT
top of the bt from gdb

#0  0x02a7bad5 in IA__gtk_tree_model_get_valist (tree_model=0x8aaf400, 
    iter=0xbffd13ec, var_args=0xbffd13b0 "\002") at gtktreemodel.c:1432
#1  0x02a7bccd in IA__gtk_tree_model_get (tree_model=0x8aaf400, 
    iter=0xbffd13ec) at gtktreemodel.c:1394
#2  0x02943600 in shortcuts_add_bookmarks (impl=0x8b5a038)
    at gtkfilechooserdefault.c:2056
#3  0x02943641 in bookmarks_changed_cb (file_system=0x8b5e050, impl=0x8b5a038)
    at gtkfilechooserdefault.c:5030
#4  0x0294373a in gtk_file_chooser_default_map (widget=0x8b5a038)
    at gtkfilechooserdefault.c:5759
#5  0x02c20139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#6  0x02c116f9 in g_value_set_static_boxed () from /lib/libgobject-2.0.so.0
#7  0x02c12fbd in g_closure_invoke () from /lib/libgobject-2.0.so.0
#8  0x02c2423a in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#9  0x02c2529e in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#10 0x02c25459 in g_signal_emit () from /lib/libgobject-2.0.so.0
#11 0x02abe0b1 in IA__gtk_widget_map (widget=0x8b5a038) at gtkwidget.c:2405
#12 0x02911d95 in gtk_container_map_child (child=0x0, client_data=0x0)
    at gtkcontainer.c:2387
#13 0x028d4230 in gtk_box_forall (container=0x8b430b8, include_internals=1, 
    callback=0x2911d70 <gtk_container_map_child>, callback_data=0x0)
    at gtkbox.c:670
#14 0x0290f68b in IA__gtk_container_forall (container=0x8b430b8, 
    callback=0x2911d70 <gtk_container_map_child>, callback_data=0x0)
    at gtkcontainer.c:1261
#15 0x02911d4b in gtk_container_map (widget=0x8b430b8) at gtkcontainer.c:2395
#16 0x02c20139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#17 0x02c116f9 in g_value_set_static_boxed () from /lib/libgobject-2.0.so.0
#18 0x02c12fbd in g_closure_invoke () from /lib/libgobject-2.0.so.0
#19 0x02c2423a in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#20 0x02c2529e in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#21 0x02c25459 in g_signal_emit () from /lib/libgobject-2.0.so.0
#22 0x02abe0b1 in IA__gtk_widget_map (widget=0x8b430b8) at gtkwidget.c:2405
#23 0x02948763 in gtk_file_chooser_dialog_map (widget=0x8b56800)
    at gtkfilechooserdialog.c:486
Comment 7 Matthias Clasen 2006-07-18 11:37:12 EDT
Should be fixed in gtk2-2.10.0-4. Please close the bug if it works for you too
on x86_64
Comment 8 Caolan McNamara 2006-07-19 03:39:43 EDT
With gtk2-2.10.0-4

(scalc.bin:3339): Gtk-CRITICAL **:
gtk_tree_model_filter_convert_iter_to_child_iter: assertion `filter_iter->stamp
== filter->priv->stamp' failed
(scalc.bin:3339): Gtk-CRITICAL **: gtk_list_store_get_value: assertion
`VALID_ITER (iter, list_store)' failed
(scalc.bin:3339): GLib-GObject-WARNING **: gtype.c:3337: type id `0' is invalid
(scalc.bin:3339): GLib-GObject-WARNING **: can't peek value table for type
`<invalid>' which is not currently referenced 


#0  0x03274b35 in IA__gtk_tree_model_get_valist (tree_model=0x98bf400,
    iter=0xbffe3bec, var_args=0xbffe3ba0 "\002") at gtktreemodel.c:1432
#1  0x03274d2d in IA__gtk_tree_model_get (tree_model=0x98bf400,
    iter=0xbffe3bec) at gtktreemodel.c:1394
#2  0x0313c666 in shortcuts_add_bookmarks (impl=0x9967038)
    at gtkfilechooserdefault.c:2062
#3  0x0313c6a1 in bookmarks_changed_cb (file_system=0x996b050, impl=0x9967038)
    at gtkfilechooserdefault.c:5036
#4  0x0313c79a in gtk_file_chooser_default_map (widget=0x9967038)
    at gtkfilechooserdefault.c:5765
#5  0x034c4139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0
#6  0x034b56f9 in g_value_set_static_boxed () from /lib/libgobject-2.0.so.0
#7  0x034b6fbd in g_closure_invoke () from /lib/libgobject-2.0.so.0
#8  0x034c823a in g_signal_override_class_closure ()
   from /lib/libgobject-2.0.so.0
#9  0x034c929e in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
#10 0x034c9459 in g_signal_emit () from /lib/libgobject-2.0.so.0
#11 0x032b7111 in IA__gtk_widget_map (widget=0x9967038) at gtkwidget.c:2405
#12 0x0310ad95 in gtk_container_map_child (child=0x0, client_data=0x0)
    at gtkcontainer.c:2387
#13 0x030cd230 in gtk_box_forall (container=0x99500b8, include_internals=1,
    callback=0x310ad70 <gtk_container_map_child>, callback_data=0x0)
    at gtkbox.c:670
#14 0x0310868b in IA__gtk_container_forall (container=0x99500b8,
    callback=0x310ad70 <gtk_container_map_child>, callback_data=0x0)
    at gtkcontainer.c:1261
#15 0x0310ad4b in gtk_container_map (widget=0x99500b8) at gtkcontainer.c:2395
#16 0x034c4139 in g_cclosure_marshal_VOID__VOID ()
   from /lib/libgobject-2.0.so.0

Comment 9 Caolan McNamara 2006-07-19 06:32:58 EDT
*** Bug 199400 has been marked as a duplicate of this bug. ***
Comment 10 Matthias Clasen 2006-07-19 16:23:51 EDT
Should be fixed in 2.10.0-5

Note You need to log in before you can comment on or make changes to this bug.