Bug 199044 - service cpuspeed stop fails
service cpuspeed stop fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-16 09:44 EDT by Jay Cliburn
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 00:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Cliburn 2006-07-16 09:44:36 EDT
Description of problem:
The command 'service cpuspeed stop' fails because, as best I can tell,
there's no /var/run/cpuspeed.pid file, and /etc/init.d/functions
__pids_pidof() (at line 164) is not otherwise finding cpuspeed's pid.
Interestingly, 'pidof cpuspeed' returns the proper pid, but 'pidof -c -o
$$ -o $PPID -o %PPID -x cpuspeed' does not.

Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-1.36.fc6.1


How reproducible:
Every time.

Steps to Reproduce:
1.  Run 'service cpuspeed stop'
2.
3.
  
Actual results:
[root@osprey ~]# service cpuspeed stop
Stopping cpuspeed:                                         [FAILED]
[root@osprey ~]#                                           [FAILED]


Expected results:
[root@osprey ~]# service cpuspeed stop
Stopping cpuspeed:                                         [OK]
[root@osprey ~]#

Additional info:
Comment 1 Jay Cliburn 2006-07-21 09:44:00 EDT
Verified fixed in kernel 2.6.17-1.2431.fc6.  Please close.

[root@osprey ~]# uname -r
2.6.17-1.2431.fc6
[root@osprey ~]# service cpuspeed stop
Stopping cpuspeed:                                         [  OK  ]
[root@osprey ~]# service cpuspeed start
Starting cpuspeed:                                         [  OK  ]
[root@osprey ~]# 
Comment 2 Dave Jones 2006-07-26 00:02:27 EDT
I think I know the real cause of this problem, and it's fixed for real in the
update I'm just building (cpuspeed-1.2.1-1.39.fc6)

Note You need to log in before you can comment on or make changes to this bug.