Bug 199045 - service restorecond stop fails
service restorecond stop fails
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-07-16 09:53 EDT by Jay Cliburn
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-18 13:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jay Cliburn 2006-07-16 09:53:40 EDT
Description of problem:
On logout of current rawhide, I notice restorecond fails to stop.  It also fails
to stop when issued the command 'service restorecond stop'.  This is because the
pid in /var/run/restorecond.pid is one less than the actual pid, so the
killproc() function in /etc/init.d/functions can't find the pid to kill.  

[root@osprey ~]# cat /var/run/restorecond.pid 
[root@osprey ~]# ps -ef | grep restorecond | grep -v grep
root      2303     1  0 21:35 ?        00:00:00 /usr/sbin/restorecond

Hand editing /var/run/restorecond.pid to make the value match the running pid
results in a successful stop.  

One result of this problem is a new restorecond for every 'service
restorecond restart' invocation, since the 'stop' fails and the 'start'

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Steps to Reproduce:
1. Run 'service restorecond stop'
Actual results:
[root@osprey ~]# service restorecond stop
Shutting down restorecond:                                 [FAILED]

Expected results:
[root@osprey ~]# service restorecond stop
Shutting down restorecond:                                 [OK]

Additional info:
Comment 1 Jay Cliburn 2006-07-16 20:28:47 EDT
I have no idea how I managed to generate two of these bug reports.  Please mark
199045 as a duplicate of 199044 (or vice versa).

Comment 2 Daniel Walsh 2006-07-17 09:32:37 EDT
Fixed in policycoreutils-1.30.17-4
Comment 3 Jay Cliburn 2006-07-17 10:37:31 EDT
Please ignore comment #1.  I'm a moron and I have visions of duplicate bugzillas
where there aren't any.  A new day brings fresh clarity.
Comment 4 Jay Cliburn 2006-07-18 10:05:29 EDT
Verified fixed for me.

[root@osprey ~]# rpm -q policycoreutils
[root@osprey ~]# service restorecond restart
Shutting down restorecond:                                 [  OK  ]
Starting restorecond:                                      [  OK  ]
[root@osprey ~]# 


Note You need to log in before you can comment on or make changes to this bug.