Bug 199046 - nash runs forever installing a new kernel
nash runs forever installing a new kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-16 10:04 EDT by Josh Boyer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 17:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2006-07-16 10:04:31 EDT
Description of problem:

It appears nash just runs forever when installing a new kernel.

Version-Release number of selected component (if applicable):

mkinitrd-5.0.47-1

How reproducible:

Always.

Steps to Reproduce:
1. yum update kernel
2. wait for it to be installed
3. continue waiting since nash runs
  
Actual results:

The yum process sits at:

Running Transaction
  Installing: kernel                       ######################### [1/1] 



Expected results:

The kernel is installed

Additional info:

ps output shows nash is running a lot:

 9515 pts/3    S+     0:05 /usr/bin/python /usr/bin/yum update kernel
 9532 pts/3    S+     0:00 /bin/sh /var/tmp/rpm-tmp.99715 2
 9537 pts/3    S+     0:00 /bin/bash /sbin/new-kernel-pkg --package kernel --mki
10122 pts/3    S+     0:00 /bin/bash /sbin/new-kernel-pkg --package kernel --mki
10124 pts/3    R+     7:51 /sbin/nash --forcequiet
Comment 1 Josh Boyer 2006-07-16 19:50:13 EDT
Just to show you I'm not on crack, here's ps output showing nash still running
from the same session started earlier:

 9515 pts/3    S+     0:05 /usr/bin/python /usr/bin/yum update kernel
 9532 pts/3    S+     0:00 /bin/sh /var/tmp/rpm-tmp.99715 2
 9537 pts/3    S+     0:00 /bin/bash /sbin/new-kernel-pkg --package kernel --mki
10122 pts/3    S+     0:00 /bin/bash /sbin/new-kernel-pkg --package kernel --mki
10124 pts/3    R+   591:03 /sbin/nash --forcequiet
Comment 2 Josh Boyer 2006-07-16 19:51:59 EDT
FYI, SELinux is disabled on this system:

[root@vader ~]# getenforce
Disabled
Comment 3 Erwin Rol 2006-07-17 03:13:54 EDT
By attaching GDB to nash it allways seems to hang at;

blkid_free_dev (dev=0x0) at dev.c:33
33      dev.c: No such file or directory.
        in dev.c
(gdb) bt
#0  blkid_free_dev (dev=0x0) at dev.c:33
#1  0x000000000044d31a in blkid_put_cache (cache=0x81ca80) at cache.c:127
#2  0x0000000000411049 in nashBlockFinish (c=0x818a00) at block.c:109
#3  0x000000000040df12 in _nashFreeContext (nc=0x7f8ad0) at lib.c:106
#4  0x0000000000408afa in main (argc=0, argv=0x7fff3ccb7418) at nash.c:2545
#5  0x00000000004e0cc0 in __libc_start_main ()
#6  0x00000000004001b9 in _start ()
Comment 4 Erwin Rol 2006-07-17 03:16:50 EDT
Executing the follwing command;
echo resolveDevice LABEL=/ | /sbin/nash --forcequiet 
will print out my root device /dev/md0 and than hang forever in the place of the
stacktrace of my previouse message.
Comment 5 Jeremy Katz 2006-07-17 17:24:23 EDT
Fixed this in CVS

Note You need to log in before you can comment on or make changes to this bug.