Bug 199049 - Can't rebuild automake16 package, fails two tests
Can't rebuild automake16 package, fails two tests
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: automake16 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-16 11:48 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 08:47:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-07-16 11:48:31 EDT
Description of problem:
Can't rebuild automake16 package, because it fails two tests:
> FAIL: depcomp2.test
> FAIL: man2.test

Version-Release number of selected component (if applicable):
automake16-1.6.3-8

How reproducible:
Everytime, just try to rebuild automake16 on a normal system e.g. having 
everything installed.

Actual results:
Can't rebuild automake16 package, fails two tests

Expected results:
Working rebuild of automake16.
Comment 1 Karsten Hopp 2006-07-19 07:14:24 EDT
It works for me:

PASS: depacl2.test
PASS: depcomp.test
PASS: depcomp2.test
PASS: depdist.test
PASS: depend.test
...
PASS: man.test
PASS: man2.test
PASS: mclean.test
PASS: mdate.test
...
Can you please run 'make -C tests check TESTS=man2.test' and 
'make -C tests check TESTS=depcomp2.test' and check the contents of
tests/testSubDir for any errors ?
Comment 2 Robert Scheck 2006-07-19 15:10:46 EDT
I looked into the .test files and saw, that autoconf is used. But I don't know 
whether this the problem is, because e.g. openssh, apr, apr-util and httpd had 
problems with autoconf-2.60-3.1. So did you use 2.60 or an earlier version?
Comment 3 Karsten Hopp 2006-07-20 10:41:50 EDT
2.60 was a mistake and shouldn't have gotten in rawhide. It slipped in during the
mass rebuild. Please downgrade to 2.59 and try again.
Comment 4 Robert Scheck 2006-07-22 21:15:18 EDT
Very strange thing...when using autoconf 2.59 for rebuilding the automake16
package, I'm getting this error:

> FAIL: lex5.test

Nevertheless, the focus should be on the original two failures of this bug
report, because autoconf 2.60 will appear in Rawhide after FC6 is released 
anyway, right?
Comment 5 Karsten Hopp 2007-03-06 08:47:02 EST
automake16-1.6.3-9 has been built for rawhide with autoconf-2.61
I think this can be closed as the checks are still enabled and I didn't get a
build failure
Comment 6 Robert Scheck 2007-03-06 09:34:58 EST
Yepp, it's okay.

Note You need to log in before you can comment on or make changes to this bug.