Bug 199059 - gtk2 gtk2-engines conflicts when running yum groupupdate
gtk2 gtk2-engines conflicts when running yum groupupdate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-16 14:46 EDT by eric magaoay
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 16:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2006-07-16 14:46:16 EDT
Description of problem:
running "yum groupupdate" will return error message due to conflict between gtk2
and gtk2-engines 

Version-Release number of selected component (if applicable):
Installed (FC5): 
    gtk2 (2.8.15-1) gtk2-engines (2.7.4-3)
Update to (FC6-dev): 
    gtk2(2.10.0-2) gtk2-engines (2.7.5-1.1)
How reproducible:
persistent

Steps to Reproduce:
1. install FC5 with following group packages: base-x and gnome-desktop
2. using the latest development tree (FC6-dev) execute:
      yum groupupdate
  
Actual results:
Error: Unable to satisfy dependencies
Error: Package gtk2 conflicts with gtk2-engines < 2.7.4-7

Expected results:
yum should proceed without error

Additional info:
"yum groupupdate gnome-desktop" gives the same error 
"yum update gtk2 gtk2-engines" gives the same error
Comment 1 Matthias Clasen 2006-07-16 15:11:35 EDT
Looks like a yum issue to me; it should figure out the right order in which to
update.
Comment 2 eric magaoay 2006-07-27 16:03:06 EDT
The latest development build dated 7-27-06 fix the problem. thanks
Comment 3 eric magaoay 2006-07-27 16:11:51 EDT
Opps. My mistake.
"yum install gnome-desktop" works but 
"yum groupinstall gnome-desktop" failed.

Also, new install by selecting gnome-desktop and base-x create NO problem.
Comment 4 Jeremy Katz 2006-07-27 17:48:53 EDT
gtk2-engines needs to be added to the multilib list, that should be done for
tomorrow's rawhide

Note You need to log in before you can comment on or make changes to this bug.