Bug 1990596 - Improve VM status messages on "Migration plan details" page when migration plan hangs
Summary: Improve VM status messages on "Migration plan details" page when migration pl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: Controller
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.2.0
Assignee: Sam Lucidi
QA Contact: Ilanit Stein
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-05 17:03 UTC by Ilanit Stein
Modified: 2021-12-09 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-09 19:20:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2021:5066 0 None None None 2021-12-09 19:20:54 UTC

Description Ilanit Stein 2021-08-05 17:03:49 UTC
Description of problem:
In MTV-2.1, there are cases where a VM migration status in the migration UI is endlessly running with no progress in the disk copy. 

The cases are detailed in:
Bug 1990581 - [DOC] Migration plan not progressing without indicating the cause in UI.

For those cases, migration plan should fail, along with indicating the cause
(not complying with some OCPv validation rule or any other reason) 

Version-Release number of selected component (if applicable):
MTV-2.1

Comment 1 Sam Lucidi 2021-10-13 19:27:38 UTC
This bug is fairly vague, but I think the majority of cases have probably been fixed due to 2.2.0's improved status reporting.

Comment 2 Fabien Dupont 2021-10-20 09:18:19 UTC
Please verify with mtv-operator-bundle-2.0.0-57 / iib:126435, or later.

Comment 3 Ilanit Stein 2021-11-14 15:50:53 UTC
The cases in Bug 1990581 were checked on MTV-2.2.0-84 - Details below.


 1. No suitable target storage as required.
Case: Migration from VMware of a 100GB disk, to NFS, when there is no PV in such a size on the cluster
Result: Migration UI show migration plan is in "Transfer disk" phase, with status "Pending" - No clear reason to what it is pending.

 2. Missing vddk-init-image configuration on the OCP cluster.
Case: No vddk-init-image configured.
Result: Migration UI show migration plan is stuck in "Initialize" phase, with no indication on that it is waiting for vddk.

Bug 2015813 - Reflect "no VDDK init image" state in Migration UI by changing MTV API
should address this.

 3. VM has no disk.
A a migration plan for a VM with no disk cannot be created in the UI, since the storage mapping step cannot be skipped. Therefore, this case is not valid when running migration from UI. 

 4. One of the validation rules fails the VM import, but the error is not 
    propagated to the migration plan.
    Examples: 
      a. VM is set to be Migratable (affinity policy) - For this we will also 
         need to document RHV procedure to how change VM to be non migratable 
         (pinned to host), or redirect to the RHV Doc.

A VM is migrated from RHV regardless to the affinity policy. In case it is set as "Migratable" there is a validation warning.
The migration pass and do not hang.

      b.  VM has USB.
    The issue is usually displayed in the migration plan create page, by the 
    validation service, as a critical warning, but if the user will miss/ignore 
    it, the migration plan will be at the state described above.  
    Also the cause is usually indicated besides the failing VM import object, 
    in the Openshift workloads->Virtualization page. 

A RHV VM that has a USB Mapped host device or Console: USB enabled pass migration and do not hang.
there is a validation warning on that. 

==================

Cases 1 & 2 still hang the plan with no clear displayed reason. They need to be fixed.
Cases 3 & 4[a,b] are no longer hanging the plan.

Moving this bug to verified since some of the cases are solved, and for the ones that are not there are separate bugs.

Comment 6 errata-xmlrpc 2021-12-09 19:20:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (MTV 2.2.0 Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:5066


Note You need to log in before you can comment on or make changes to this bug.