Bug 199061 - Broken dependencies for fluxbox
Summary: Broken dependencies for fluxbox
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fluxbox (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 188220
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-16 20:17 UTC by Michael J Knox
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 04:01:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael J Knox 2006-07-16 20:17:48 UTC
This has been in the broken dependencies report for sometime now. If its not to
be supported in the FE 3 releases, then prehaps you should request it be removed
form the FE 3 repos?

------

Summary of broken packages (by owner):
----------------------------------------------------------------------
    andreas.bierfert AT lowlatency.de
        fluxbox - 0.9.15.1-1.fc3.i386
        fluxbox - 0.9.15.1-1.fc3.x86_64


Summary of broken packages in fedora-extras-3-i386:
----------------------------------------------------------------------
    fluxbox-0.9.15.1-1.fc3.i386  requires  pyxdg

Summary of broken packages in fedora-extras-3-x86_64:
----------------------------------------------------------------------
    fluxbox-0.9.15.1-1.fc3.x86_64  requires  pyxdg

Comment 1 Andreas Bierfert 2006-07-18 09:13:04 UTC
Well maybe I should but then again: If I remember correctly I tested pyxdg on
fc3 and it worked just fine so I expect that the maintainer at least sais
something like: No I won't push a build because foo breaks bar thus leading to
void. Or something. If I take the time to fill a bugreport and test stuff I'd
rather see a response... there is really no sense in having a uptodate branch of
it and not having a release. Of course it was my fault not to check the actually
released stuff and only take a quick look at the cvs files but still... I'd
rather see an answer. If I don't get one till fluxbox 1.0 release (which should
be anytime now ;)) I will fix it.

Comment 2 Michael Schwendt 2006-07-18 14:23:46 UTC
Andreas, pyxdg was available for FE3, but contained a broken Python
requirement (see separate bug report about that). Apparently, it was
removed from the repo without tracking that on the FC3Status page.


Comment 3 Andreas Bierfert 2006-07-31 13:41:09 UTC
So what does this mean Michael? Will there be another try for pyxdg on FC3 or
not? If not I will fix the Requires...

Comment 4 Michael Schwendt 2006-07-31 18:05:07 UTC
It means nothing else than at some point back in time there was
a release of pyxdg for Fedora Extras 3, so creating a dependency
on it was valid. That pyxdg package was broken, however, and made
it into the broken deps report around Oct/Nov 2005. An unknown time
later the package got removed from the repository without tracking.

FE CVS of pyxdg still has an FC-3 branch which contains an old but
upgraded version which has not been built and published. Whether it
still suffers from the same old breakage, I don't know.



Comment 5 Andreas Bierfert 2006-08-28 04:01:51 UTC
Well not a bug anymore as pyxdg is pushed now for FE3.


Note You need to log in before you can comment on or make changes to this bug.