Bug 1990998 - ERF42-5962 Error when attempting to customize module install
Summary: ERF42-5962 Error when attempting to customize module install
Keywords:
Status: CLOSED DUPLICATE of bug 1970074
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.10.0
Assignee: Jonathon Turel
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-06 18:35 UTC by Stephen Wadeley
Modified: 2021-08-18 14:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-18 14:45:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 33243 0 None None None 2021-08-11 18:36:36 UTC

Description Stephen Wadeley 2021-08-06 18:35:57 UTC
Description of problem:

Error when attempting to customize module install

Oops, we're sorry but something went wrong ERF42-5962 [Foreman::Exception]: No template mapped to feature Katello: Module Stream Actions



Version-Release number of selected component (if applicable):
6.10.0-12.0

How reproducible:
test fails every time


Steps to Reproduce:
1. Install walrus, then dnf module reset walrus
2. Search: name = walrus and stream = 5.21
3. From Actions menu, select Customize, select Install

Actual results:
Oops, we're sorry but something went wrong ERF42-5962 [Foreman::Exception]: No template mapped to feature Katello: Module Stream Actions

Expected results:
job_template_selector is displayed
Remote execution for module actions should succeed


Additional info:
will attach foreman-rake error log

Comment 2 Brad Buckingham 2021-08-09 13:23:40 UTC
Is this a regression from Satellite 6.9?

Comment 8 Jonathon Turel 2021-08-11 18:36:35 UTC
Connecting redmine issue https://projects.theforeman.org/issues/33243 from this bug

Comment 9 Jonathon Turel 2021-08-18 14:45:56 UTC

*** This bug has been marked as a duplicate of bug 1970074 ***


Note You need to log in before you can comment on or make changes to this bug.