Bug 199131 - Unexpected kernel-API changes after updating from 2.6.17-1.2145_FC5 to 2.6.17-1.2157_FC5
Unexpected kernel-API changes after updating from 2.6.17-1.2145_FC5 to 2.6.17...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 10:05 EDT by Dmitry Butskoy
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 21:46:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2006-07-17 10:05:23 EDT
Description of problem:
There are some unexpected kernel-API changes in 2.6.17-1.2157_FC5.

Compare file "include/linux/skbuff.h" from kernel-devel-2.6.17-1.{2139|2145} and
from 2157. At least "struct skb_shared_info" was changed (tso_size --> gso_size
etc.)

Some 3rd-party network card modules cannot be compiled easy any more because of
this.

IMHO it is not a good idea to do any API changes in the *same* kernel version
(2.6.17).

As these changes was for support Xen kernels only, maybe #ifdef them someway?



Version-Release number of selected component (if applicable):
2.6.17-1.2157_FC5
Comment 1 Dmitry Butskoy 2006-07-17 10:10:17 EDT
Additional info:

The changes was inspired by the newest linux-2.6-xen.patch ...
Comment 2 Dmitry Butskoy 2006-07-27 07:36:05 EDT
"gso_size" above appears in 2.6.18 ...


It seems that linux-2.6-xen.patch was generated by running "diff" with the
2.6.17 source and some Xen-modified 2.6.18 source (instead of some "Xen-modified
2.6.17 source").
Comment 3 Dave Jones 2006-09-10 21:46:45 EDT
There is no stable kernel API across releases upstream, and hence, there isn't
one in Fedora either.

Note You need to log in before you can comment on or make changes to this bug.