Bug 199139 - Interfaces get mixed up when using ccwgroups and ONBOOT=no
Interfaces get mixed up when using ccwgroups and ONBOOT=no
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
urgent Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 198694 202218 234547
  Show dependency treegraph
 
Reported: 2006-07-17 10:32 EDT by Bastien Nocera
Modified: 2014-03-16 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0303
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
initscripts-s390x-onboot-qeth.patch (3.34 KB, patch)
2006-07-17 10:32 EDT, Bastien Nocera
no flags Details | Diff
patch for this issue (701 bytes, patch)
2006-12-07 17:27 EST, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2006-07-17 10:32:07 EDT
initscripts-7.93.24.EL-1.1

On zSeries, using qeth interfaces

1. Set up 3 interfaces (eth0, eth1, eth2)
2. Setup eth0 and eth2 to be ONBOOT=yes
3. Setup eth1 to be ONBOOT=no
4. See that /proc/qeth shows eth0 and eth1 as being setup, instead of eth0, eth1
and eth2 (eth1 is initialised, but not up)

The attached patches from bhinson@redhat.com fix the problem
Comment 1 Bastien Nocera 2006-07-17 10:32:08 EDT
Created attachment 132547 [details]
initscripts-s390x-onboot-qeth.patch
Comment 7 Bill Nottingham 2006-07-24 12:09:18 EDT
Realistically, this should all be udev rules... it should see the qeth devices
on boot, load the appropriate module, and a udev script should configure the
devices.
Comment 9 RHEL Product and Program Management 2006-08-18 11:08:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Bill Nottingham 2006-12-07 17:27:27 EST
Created attachment 143097 [details]
patch for this issue

Please test that this works for you - this works for me in testing the scenario
mentioned above. This is what I'm planning to commit for 7.93.26.EL-1 and
later.
Comment 17 Red Hat Bugzilla 2007-05-01 13:29:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0303.html

Note You need to log in before you can comment on or make changes to this bug.