Bug 199143 - stage1 anaconda w/DHCP: "There was an error configuring your network interface."
stage1 anaconda w/DHCP: "There was an error configuring your network interface."
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-17 11:04 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 14:00:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-07-17 11:04:09 EDT
Description of problem:
I am seeing this on my HP Integrity servers with e1000 and e100 NICs (I do not
have any other NIC's to test at this time).

When doing a network based install and using DHCP to set up the networking
anaconda gives the error "There was an error configuring your network
interface." and it gives me a "Retry" button.

I have seen this both with a kickstart install using ksdevice=eth0 as well as
with an interactive install.  I have also tried with and without the IPv6 box
checked.  When I do not use DHCP it works properly.


Version-Release number of selected component (if applicable):
rawhide-20060712 (note, this is the most recent good build for ia64 so I cannot
test newer at this point).

anaconda-11.1.0.56-1


How reproducible:
100%

Steps to Reproduce:
1. boot the installer
2. select NFS, http, or ftp install source
3. select DHCP
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2006-07-17 11:07:06 EDT
What messages are printed on VT3?
Comment 2 Doug Chapman 2006-07-17 11:11:38 EDT
All of my systems are headless so I only have serial console.  I really wish I
had a way to get that info as I do realize it would make things much easier to
debug.  Is there some magic way to get at this?
Comment 3 David Cantrell 2006-07-17 11:14:57 EDT
You'll laugh, but you can use the remote logging feature.  Send syslog messages
to a remote system.  Boot with these options:

loglevel=debug syslog=somebox.location.redhat.com

Set up syslogd to accept remote logging.

*BUT*, since this is a network issue, that's not really going to help.  You said
that this is using anaconda 11.1.0.56.  In that build, the version of libdhcp
used still tried to write out /etc/resolv.conf and would fail.  The anaconda
loader was trapping that error successfully, but unfortunately it wouldn't let
you proceed and you'd end up in the retry loop.

If you can get a tree that's using anaconda-11.1.0.57, that's built against a
libdhcp that does not have that problem.
Comment 4 Doug Chapman 2006-07-17 11:19:50 EDT
Dave,

This doesn't help me right now but the is AWSOME for other anaconda issues.  I
will certainly try the remote logging next time I see an anaconda issue!

I cannot currently use more recent trees because of panic and build issues but I
will re-try this as soon as something is available.

thanks,

- Doug
Comment 5 David Cantrell 2006-07-17 16:19:41 EDT
Doug,

Sounds good.  The retry loop is most likely the /etc/resolv.conf writeout, which
has been fixed.  Also, I'm going to close 196701 since it's sort of the same bug
as listed here, but this one is in a more advanced state.

-David
Comment 6 David Cantrell 2006-08-02 13:27:28 EDT
Doug,

Where are we on this bug?  Is it still present in current rawhide trees?

-David
Comment 7 Doug Chapman 2006-08-02 14:00:37 EDT
David,

sorry, should have closed this one out a while back.  Seems to be working now.

Note You need to log in before you can comment on or make changes to this bug.