Bug 199145 - Multihome patch does not support IPv6
Multihome patch does not support IPv6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ftp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Ben Levenson
:
Depends On:
Blocks: 171621 IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-17 11:23 EDT by Ludek Smid
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 09:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix (3.40 KB, patch)
2006-07-28 10:52 EDT, Peter Vrabec
no flags Details | Diff

  None (edit)
Description Ludek Smid 2006-07-17 11:23:54 EDT
Description of problem:

The IPv6 is not correctly supported on multihome machines because of ftp
multihome patch is not IPv6 compliant.

Version-Release number of selected component (if applicable):
0.17-32.1.2.1

How reproducible:
Always.

Steps to Reproduce:
1. Connect to ftp server using IPv6 protocol from multihome host
2. Login
3. Execute command 'dir'
  
Actual results:
$ /usr/bin/ftp ipv6srot6.ipv6.redhat.usu
Connected to ipv6srot6.ipv6.redhat.usu (fec0::f101:210:5aff:fed5:7e33).
220 (vsFTPd 2.0.4)
Name (ipv6srot6.ipv6.redhat.usu:lsmid): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
use of scoped address can be troublesome
ftp multihome bind: Invalid argument
ftp>

Expected results:
The content of the directory

Additional info:
N/A
Comment 1 Peter Vrabec 2006-07-28 10:52:26 EDT
Created attachment 133239 [details]
fix

Note You need to log in before you can comment on or make changes to this bug.