Bug 199190 - python plugins importing C code seem to fail
Summary: python plugins importing C code seem to fail
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libopensync-plugin-python   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-17 20:49 UTC by Thomas Vander Stichele
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 13:13:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Vander Stichele 2006-07-17 20:49:22 UTC
Description of problem:
I have made a simple python plugin for opensync, but it fails to load.

Version-Release number of selected component (if applicable):
0.18-3

How reproducible:
always

Steps to Reproduce:
1. in /usr/lib/opensync/python-plugins, copy sample.py to sample2.py
2. add a new first line: import operator
3. run osyncplugin testmodule

  
Actual results:
Traceback (most recent call last):
  File "/usr/lib/opensync/python-plugins/sample2.py", line 1, in ?
    import operator
ImportError: /usr/lib/python2.4/lib-dynload/operator.so: undefined symbol:
_PyArg_NoKeywords
Emptying requested sources (Access available: No)
Connect called!!




Expected results:

the import should work

Additional info:

seems to be fixed with a rebuild for this package so that it is built against
python 2.4.2, not 2.4.1
may also affect fc5 and devel

Comment 1 Andreas Bierfert 2006-07-18 09:22:58 UTC
thanks... will be included with all the other opensync related bugs on my list
sometime this week... if not keep buging me ;)

Comment 2 Thomas Vander Stichele 2006-09-02 10:55:43 UTC
consider yourself bugged :)

Comment 3 Andreas Bierfert 2006-10-20 13:13:44 UTC
Pushed.


Note You need to log in before you can comment on or make changes to this bug.