Bug 199226 - Radeon Mobility 9000 requires vbetool post and restore on resume
Radeon Mobility 9000 requires vbetool post and restore on resume
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
  Show dependency treegraph
Reported: 2006-07-18 00:33 EDT by Robert Hancock
Modified: 2013-03-05 22:46 EST (History)
5 users (show)

See Also:
Fixed In Version: 20090202-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-27 21:08:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
updated configuration file for hal (3.77 KB, application/octet-stream)
2007-07-14 17:11 EDT, Wilfried Philips
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 19362 None None None Never

  None (edit)
Description Robert Hancock 2006-07-18 00:33:23 EDT
Description of problem:

Video does not resume properly after suspend to RAM on a Compaq Presario X1050
with Radeon Mobility 9000 video. The screen remains all white and filled with
streaks. For video to resume properly the following appears needed:


/usr/sbin/vbetool vbestate save > /var/run/vbestate

to suspend_video() before the "vbetool dpms suspend"


/usr/sbin/vbetool post
/usr/sbin/vbetool vbestate restore < /var/run/vbestate

to resume_video() before "vbetool dpms on"

Either the "vbetool post" or "vbetool vbestate restore" will do the trick just
to get back into X, but to be able to get back into text console afterwards,
both appear to be needed.

Of course it's quite possible that adding this will break some systems with ATI
video, so this may need to be system-specific or user configurable (or else a
better solution needs to be devised).

Version-Release number of selected component (if applicable):


How reproducible:

Every time

Steps to Reproduce:
1. Suspend above laptop
2. Resume laptop
Actual results:

Video is garbled

Expected results:

Video displays properly

Additional info:
Comment 1 Phil Knirsch 2007-01-23 11:11:21 EST
Have you tried this with newer version of pm-utils? There are quite a few 
changes in the FC6 version of it that might fix the problem you're describing.


Read ya, Phil
Comment 2 Robert Hancock 2007-07-14 03:35:29 EDT
This is still not working in Fedora 7. When resuming from suspend to RAM with
the default scripts, I still get just the same streaky gray screen as before.
Comment 3 Wilfried Philips 2007-07-14 17:11:02 EDT
Created attachment 159274 [details]
updated configuration file for hal
Comment 4 Wilfried Philips 2007-07-14 17:12:21 EDT
I can confirm this on an acer travelmate 803LMi.

I was able to solve it by adding the following lines 

  <match key="system.hardware.product" prefix="TravelMate 800">
          <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
          <merge key="power_management.quirk.vbestate_restore"


See the updated file in attachment

I found this by following the procedure described on 

I still have other hibernation and suspend problems.
Comment 5 Till Maas 2007-08-30 11:18:19 EDT
Wilfried and Robert, can you both paste the output of:

lshal | egrep "(system.hardware.(product|vendor|version)|smbios.bios.version)"

This contains all information that may be needed to identify you notebooks.
Comment 6 Till Maas 2007-10-03 11:37:27 EDT
The fdi information is part of hal-info, therefore I reassign/change the
component of this bug.
Comment 7 Jon Stanley 2008-01-11 23:06:11 EST
As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.
Comment 8 Robert Hancock 2008-07-18 00:01:47 EDT
This problem still occurs in Fedora 9. I fixed it by editing
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi to add
X1000 to the models list for this section:

      <match key="system.hardware.product" contains_outof="OmniBook XE3
        <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
        <merge key="power_management.quirk.vbestate_restore"


      <match key="system.hardware.product" contains_outof="OmniBook XE3

This system is similar to the nx7000 (the ACPI tables identification even says
nx7000) so this makes sense.

My system's model info is:

  system.hardware.product = 'Compaq Presario X1000 DP485U#ABL'  (string)
  system.hardware.vendor = 'Hewlett-Packard'  (string)
  system.hardware.version = 'F.55'  (string)

Comment 9 Robert Hancock 2008-11-26 00:40:30 EST
Still a problem in Fedora 10. Patch above still required.
Comment 10 Robert Hancock 2009-01-17 19:28:27 EST
Patch merged into upstream git:

Comment 11 Robert Hancock 2009-02-27 21:08:21 EST
Problem is resolved in hal-info-20090202-1.fc10.

Note You need to log in before you can comment on or make changes to this bug.