Bug 199232 - CVE-2006-3627 Mulitple security issues (CVE-2006-3628 CVE-2006-3629 CVE-2006-3630 CVE-2006-3631 CVE-2006-3632)
CVE-2006-3627 Mulitple security issues (CVE-2006-3628 CVE-2006-3629 CVE-2006-...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ethereal (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
reported=20060717,public=20060717,sou...
: Security
Depends On: 199231
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 03:13 EDT by Mark J. Cox (Product Security)
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHSA-2006-0602
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 09:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark J. Cox (Product Security) 2006-07-18 03:13:58 EDT
From http://www.wireshark.org/security/wnpa-sec-2006-01.html

Name: Multiple problems in Ethereal® versions 0.8.14 to 0.10.10

Docid: wnpa-sec-2006-01

Date: July 17, 2006

Versions affected: 0.8.16 up to and including 0.99.0
Details
Description
Wireshark 0.99.2 fixes the following vulnerabilities:

    * The GSM BSSMAP dissector could crash. Versions affected: 0.10.11. CVE:
CVE-2006-3627 

Ilja van Sprundel discovered the following vulnerabilities:

    * The ANSI MAP dissector was vulnerable to a format string overflow.
Versions affected: 0.10.0. CVE: CVE-2006-3628
    * The Checkpoint FW-1 dissector was vulnerable to a format string overflow.
Versions affected: 0.10.10. CVE: CVE-2006-3628
    * The MQ dissector was vulnerable to a format string overflow. Versions
affected: 0.10.4. CVE: CVE-2006-3628
    * The XML dissector was vulnerable to a format string overflow. Versions
affected: 0.10.13. CVE: CVE-2006-3628
    * The MOUNT dissector could attempt to allocate large amounts of memory.
Versions affected: 0.9.4. CVE: CVE-2006-3629
    * The NCP NMAS and NDPS dissectors were susceptible to off-by-one errors.
Versions affected: 0.9.7. CVE: CVE-2006-3630
    * The NTP dissector was vulnerable to a format string overflow. Versions
affected: 0.10.13. CVE: CVE-2006-3628
    * The SSH dissector was vulnerable to an infinite loop. Versions affected:
0.9.10. CVE: CVE-2006-3631
    * The NFS dissector may have been susceptible to a buffer overflow. Versions
affected: 0.8.16. CVE: CVE-2006-3632 

Impact
It may be possible to make Ethereal crash, use up available memory, or run
arbitrary code by injecting a purposefully malformed packet onto the wire or by
convincing someone to read a malformed packet trace file.
Resolution
Upgrade to Wireshark 0.99.2.

If are running Ethereal 0.99.0 or earlier and cannot upgrade, you can disable
each of the dissectors listed above by doing the following:

    * Select Analyze→Enabled Protocols... from the menu.
    * Make sure every protocol listed above is un-checked.
    * Click "Save", then click "OK".
Comment 1 Mark J. Cox (Product Security) 2006-07-18 03:14:32 EDT
Also affects RHEL3, RHEL2.1
Comment 3 Red Hat Bugzilla 2006-08-16 09:42:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2006-0602.html

Note You need to log in before you can comment on or make changes to this bug.