Bug 1992720 - Upgrade Ingress API version
Summary: Upgrade Ingress API version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.8.z
Assignee: Samuel Padgett
QA Contact: Xiyun Zhao
URL:
Whiteboard:
Depends On: 1990577
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-11 16:12 UTC by OpenShift BugZilla Robot
Modified: 2021-09-07 04:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-07 04:14:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 9788 0 None None None 2021-08-25 12:01:48 UTC
Red Hat Product Errata RHBA-2021:3299 0 None None None 2021-09-07 04:14:19 UTC

Description OpenShift BugZilla Robot 2021-08-11 16:12:18 UTC
+++ This bug was initially created as a clone of Bug #1990577 +++

Description of problem:
The version we are currently using (v1beta1) is going away from upstream Kubernetes and should be updated to `v1`.  See https://kubernetes.io/docs/reference/using-api/deprecation-guide/#ingress-v122

Note this will be required for 4.9

Version-Release number of selected component (if applicable):
4.9

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 Xiyun Zhao 2021-08-31 10:41:13 UTC
This bug has been fixed and verified on payload 4.9.0-0.nightly-2021-08-30-192239

Verification steps:
1. Log on OCP and navigate to Networking -> Ingresses page
2. Click the 'Create Ingress' button on the top right corner of the Ingresses page
3. Check if the 'apiVersion' is 'networking.k8s.io/v1' and more information is as shown below on default YAML editor page
    apiVersion: networking.k8s.io/v1
    kind: Ingress
    metadata:
      name: example
      namespace: xiyuntest
    spec:
      rules:
        - host: example.com
          HTTP:
            paths:
              - path: /testpath
                pathType: Prefix
                backend:
                  service:
                    name: test
                    port:
                      number: 80
4. After creating Ingress successfully, check the Ingress details page of the new create ingress
5. Zoom in/out the page, or adjust the browser size, check the column of Ingress rules part
6. Check if i18n mode is not impacted on this change, add '?pseudolocalization=true&lng=en' at the end of the URL

Result:
3. The new format of Ingress is correct, 
      1) API version is update from 'v1beta1' to 'v1'
      2) One parameter pathType:Prefix is added under paths
      3) the service information which with name and port number's value is also added under paths
5. The column of  'Path type', 'service', 'Service port' will hide when the user adjusts the browse size or zooms in/out. all content is shown correctly
6. This change is not impact the i18n mode, all content on Ingress page is translate correctly

Comment 8 errata-xmlrpc 2021-09-07 04:14:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.10 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3299


Note You need to log in before you can comment on or make changes to this bug.