Bug 1992893 - [FTBFS] pcl: FTBS in rawhide
Summary: [FTBFS] pcl: FTBS in rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Mattes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1991887
TreeView+ depends on / blocked
 
Reported: 2021-08-11 23:08 UTC by Thomas Rodgers
Modified: 2021-11-04 21:24 UTC (History)
4 users (show)

Fixed In Version: pcl-1.12.0-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-04 21:09:48 UTC
Type: Bug


Attachments (Terms of Use)
build.log (25.78 KB, text/plain)
2021-08-11 23:08 UTC, Thomas Rodgers
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github PointCloudLibrary pcl issues 4882 0 None None None 2021-08-13 22:15:47 UTC

Description Thomas Rodgers 2021-08-11 23:08:30 UTC
Created attachment 1813278 [details]
build.log

Description of problem:

Fails to build from source.

CMake Error at cmake/pcl_targets.cmake:305 (add_executable):
  Target "pcl_openni_face_detector" links to target "Boost::serialization"
  but the target was not found.  Perhaps a find_package() call is missing for
  an IMPORTED target, or an ALIAS target is missing?

Comment 1 Adam Williamson 2021-08-13 22:15:47 UTC
I'm working on this, but got a bit stuck.

There's an upstream 1.12.0. Using that and building against the vtk rebuild that happened recently gets past boost issues, but then we run into https://github.com/PointCloudLibrary/pcl/issues/4882 :

[ 86%] Built target pcl_obj_rec_ransac_result
CMakeFiles/pcl_surface.dir/src/mls_xyz.cpp.o: in function `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const':
/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: multiple definition of `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const'; CMakeFiles/pcl_surface.dir/src/mls_n.cpp.o:/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: first defined here
/usr/bin/ld: CMakeFiles/pcl_surface.dir/src/mls_xyzi.cpp.o: in function `Eigen::internal::handmade_aligned_malloc(unsigned int)':
/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:493: multiple definition of `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const'; CMakeFiles/pcl_surface.dir/src/mls_n.cpp.o:/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: first defined here
/usr/bin/ld: CMakeFiles/pcl_surface.dir/src/mls_xyzrgba.cpp.o: in function `Eigen::internal::handmade_aligned_malloc(unsigned int)':
/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:493: multiple definition of `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const'; CMakeFiles/pcl_surface.dir/src/mls_n.cpp.o:/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: first defined here
/usr/bin/ld: CMakeFiles/pcl_surface.dir/src/mls_xyzrgb.cpp.o: in function `Eigen::internal::handmade_aligned_malloc(unsigned int)':
/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:493: multiple definition of `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const'; CMakeFiles/pcl_surface.dir/src/mls_n.cpp.o:/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: first defined here
/usr/bin/ld: CMakeFiles/pcl_surface.dir/src/mls_xyzrgbn.cpp.o: in function `Eigen::internal::handmade_aligned_malloc(unsigned int)':
/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:493: multiple definition of `pcl::MLSResult::calculatePrincipalCurvatures(double, double) const'; CMakeFiles/pcl_surface.dir/src/mls_n.cpp.o:/builddir/build/BUILD/pcl-1.12.0/surface/include/pcl/surface/impl/mls.hpp:538: first defined here
collect2: error: ld returned 1 exit status
gmake[2]: *** [surface/CMakeFiles/pcl_surface.dir/build.make:592: lib/libpcl_surface.so.1.12.0] Error 1

Comment 2 Rich Mattes 2021-08-17 19:21:58 UTC
Thanks for taking a look, I had a busy last week/weekend but I should be able to resolve this this week.

That error looks like it's at least partly caused by a patch that splits up some template instantiations so that builders don't hit OOM errors, I'll try building with the patch disabled and see what happens

Comment 3 Adam Williamson 2021-08-17 19:37:07 UTC
Thanks, Rich. I did have to rebase three patches and remove another to get that far; I'll commit that work to the rawhide branch so you don't have to recreate it.

Comment 4 Fedora Update System 2021-11-04 21:24:50 UTC
FEDORA-2021-f230a6fe6a has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.