Bug 1992900 - openshift/kubernetes fails to build on ARM
Summary: openshift/kubernetes fails to build on ARM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.9
Hardware: aarch64
OS: Linux
urgent
urgent
Target Milestone: ---
: 4.9.0
Assignee: Yaakov Selkowitz
QA Contact: Rahul Gangwar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-11 23:33 UTC by Yaakov Selkowitz
Modified: 2021-10-18 17:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-18 17:45:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github kubernetes kubernetes pull 104315 0 None None None 2021-08-11 23:33:58 UTC
Github openshift kubernetes pull 886 0 None None None 2021-08-11 23:38:23 UTC
Red Hat Product Errata RHSA-2021:3759 0 None None None 2021-10-18 17:46:14 UTC

Description Yaakov Selkowitz 2021-08-11 23:33:58 UTC
The hyperkube image has been failing in OSBS since the kube rebase. the problem is specific to ARM, where we've observed that oddities of that cluster cause it to run up against resource constraints. we have worked around that in the past by adding -p=8 to GOFLAGS when running make.

however when that was tried for hyperkube (make GOFLAGS='-mod=vendor -p=8' WHAT='...), it broke the build:

--> RUN make GOFLAGS='-mod=vendor -p=8' WHAT='cmd/kube-apiserver cmd/kube-controller-manager cmd/kube-scheduler cmd/kubelet cmd/watch-termination' &&     mkdir -p /tmp/build &&     cp openshift-hack/images/hyperkube/hyperkube /tmp/build &&     cp /go/src/k8s.io/kubernetes/_output/local/bin/linux/$(go env GOARCH)/{kube-apiserver,kube-controller-manager,kube-scheduler,kubelet,watch-termination}     /tmp/build
+++ [0811 21:46:54] Building go targets for linux/amd64:
    ./vendor/k8s.io/code-generator/cmd/prerelease-lifecycle-gen
cmd/go: -tags space-separated list contains comma
!!! [0811 21:46:54] Call tree:
!!! [0811 21:46:54]  1: /go/src/k8s.io/kubernetes/hack/lib/golang.sh:732 kube::golang::build_some_binaries(...)
!!! [0811 21:46:54]  2: /go/src/k8s.io/kubernetes/hack/lib/golang.sh:876 kube::golang::build_binaries_for_platform(...)
!!! [0811 21:46:54]  3: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
!!! [0811 21:46:54] Call tree:
!!! [0811 21:46:54]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
!!! [0811 21:46:54] Call tree:
!!! [0811 21:46:54]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
make[1]: *** [Makefile.generated_files:208: _output/bin/prerelease-lifecycle-gen] Error 1
make: *** [Makefile:552: generated_files] Error 2

Comment 2 Rahul Gangwar 2021-09-07 07:19:41 UTC
Build is success with latest arm payload 

Job id : Flexy-install/40456/
 
oc get clusterversion                                 
NAME      VERSION                                   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.9.0-0.nightly-arm64-2021-09-01-193919   True        False         18h     Cluster version is 4.9.0-0.nightly-arm64-2021-09-01-193919

Comment 5 errata-xmlrpc 2021-10-18 17:45:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.9.0 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:3759


Note You need to log in before you can comment on or make changes to this bug.