Bug 1993 - rpm warns Japanese JIS text in spec file as binary
Summary: rpm warns Japanese JIS text in spec file as binary
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-05 02:19 UTC by inoue
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-05 15:34:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description inoue 1999-04-05 02:19:23 UTC
When we Japanese write some Japanese text in spec file like
this: Summary(ja): xxxxxxxx, rpm warns this file as binary
and exits if we use JIS kanji code for this text.
In Japan, commonly used kanji code for Linux is EUC-JP and
no problem occurs when we use EUC-JP in spec file, but
someone want to use JIS kanji code because JIS (ISO-2022-JP)
is also used widely, especially in mail, and EUC-JP itself
is based on JIS.
So please omit checking out ESC (0x1b) at this point:

diff -uNr rpm-2.5.5/build.c rpm-2.5.5.new/build.c
--- rpm-2.5.5/build.c	Fri Sep 25 05:23:16 1998
+++ rpm-2.5.5.new/build.c	Sat Apr  3 15:28:13 1999
@@ -128,7 +128,7 @@
     close(fd);
     s = buf;
     while(count--) {
-	if (! (isprint(*s) || isspace(*s))) {
+	if (! (isprint(*s) || isspace(*s) || (*s == 0x1b))) {
 	    fprintf(stderr, _("File contains non-printable
characters(%c): %s\n"), *s,
 		    specfile);
 	    ret

Comment 1 Jeff Johnson 1999-04-05 15:24:59 UTC
Fixed in rpm CVS. Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.