Bug 1993189 - authselect doesn't properly obsolete/provide authselect-compat
Summary: authselect doesn't properly obsolete/provide authselect-compat
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: authselect
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Březina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1995520 (view as bug list)
Depends On:
Blocks: F35BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-08-12 13:55 UTC by Matt Fagnani
Modified: 2021-08-19 15:43 UTC (History)
5 users (show)

Fixed In Version: authselect-1.2.4-2.fc35 authselect-1.2.4-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-14 14:27:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Matt Fagnani 2021-08-12 13:55:24 UTC
Description of problem:

I ran sudo dnf upgrade --refresh in a Fedora 35 KDE Plasma installation. A dnf error indicated a problem with authselect-compat and authselect-1.2.4-1.fc35.

Problem: cannot install both authselect-1.2.4-1.fc35.x86_64 and authselect-1.2.3-4.fc35.x86_64
  - package authselect-compat-1.2.3-4.fc35.x86_64 requires authselect(x86-64) = 1.2.3-4.fc35, but none of the providers can be installed
  - cannot install the best update candidate for package authselect-1.2.3-4.fc35.x86_64
  - problem with installed package authselect-compat-1.2.3-4.fc35.x86_64

authselect-compat was removed from authselect-1.2.4-1.fc35. https://src.fedoraproject.org/rpms/authselect/c/5b2aadc5ec6bcd9adca994afcb60328123a936d8?branch=rawhide
https://koji.fedoraproject.org/koji/buildinfo?buildID=1816035

Obsoleting authselect-compat might resolve the error.

Version-Release number of selected component (if applicable):
authselect-1.2.4-1.fc35.x86_64 

How reproducible:
2 of 2 times

Steps to Reproduce:
1. Boot a Fedora 35 KDE Plasma installation updated to 2021-8-11
2. sudo dnf upgrade --refresh
3.

Actual results:
authselect-compat-1.2.3-4.fc35.x86_64 requires authselect(x86-64) = 1.2.3-4.fc35, but none of the providers can be installed

Expected results:
No error would happen.

Additional info:

Comment 1 Peter Robinson 2021-08-13 12:03:08 UTC
Same here, it's not properly obsoleted/provided in the spec.

Error: 
 Problem: package authselect-compat-1.2.3-4.fc35.aarch64 requires authselect(aarch-64) = 1.2.3-4.fc35, but none of the providers can be installed
  - authselect-1.2.3-4.fc35.aarch64 does not belong to a distupgrade repository
  - problem with installed package authselect-compat-1.2.3-4.fc35.aarch64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 2 Fedora Blocker Bugs Application 2021-08-13 12:04:37 UTC
Proposed as a Blocker for 35-beta by Fedora user pbrobinson using the blocker tracking app because:

 Upgrade path broken for standard configurations.

Comment 3 Fedora Update System 2021-08-14 14:25:38 UTC
FEDORA-2021-b1627a59d9 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b1627a59d9

Comment 4 Fedora Update System 2021-08-14 14:26:31 UTC
FEDORA-2021-66a73d8089 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-66a73d8089

Comment 5 Fedora Update System 2021-08-14 14:27:51 UTC
FEDORA-2021-66a73d8089 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2021-08-14 14:27:55 UTC
FEDORA-2021-b1627a59d9 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Adam Williamson 2021-08-19 15:43:04 UTC
*** Bug 1995520 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.