Bug 1993259 - Enable migration of RHV VM with non-UTC time zone
Summary: Enable migration of RHV VM with non-UTC time zone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: Controller
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.2.0
Assignee: Sam Lucidi
QA Contact: Amos Mastbaum
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-12 16:11 UTC by Amos Mastbaum
Modified: 2021-12-09 19:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-09 19:20:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2021:5066 0 None None None 2021-12-09 19:20:54 UTC

Description Amos Mastbaum 2021-08-12 16:11:30 UTC
Description of problem:

With MTV 2.1.0 / CNV 4.8.z, VMIO blocks the migration of RHV VMs configured with a non-UTC timezone.

 - lastHeartbeatTime: "2021-08-12T16:02:24Z"
    lastTransitionTime: "2021-08-12T15:55:43Z"
    message: VM's timezone is not UTC-compatible. It should have offset of 0 and not observe DST
    reason: MappingRulesVerificationFailed
    status: "False"
    type: MappingRulesVerified

The full VirtualMachineImport CR is attached to this bug.

With https://github.com/kubevirt/kubevirt/pull/3973, Kubevirt supports setting the timezone in the VirtualMachine spec.
This means that during the migration of a virtual machine from RHV, the timezone can and must be kept.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. In RHV, create a virtual machine with a non-UTC timezone.
2. IN MTV, create a plan with the newly created virtual machine.
3. Start the plan.
4. Watch the VirtualMachineImport, Migration and Plan CRs.

Actual results:
The plan is in running state and the "faulty" virtual machine migration hangs.

Expected results:
The VirtualMachine CR created by MTV should reflect the timezone of the source virtual machine in RHV.

Additional info:

Comment 1 Fabien Dupont 2021-10-20 09:18:35 UTC
Please verify with mtv-operator-bundle-2.0.0-57 / iib:126435, or later.

Comment 2 Amos Mastbaum 2021-10-29 07:24:16 UTC
verified MTV 2.2.0-63

Comment 5 errata-xmlrpc 2021-12-09 19:20:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (MTV 2.2.0 Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:5066


Note You need to log in before you can comment on or make changes to this bug.