Bug 199333 - rpmbuild segfaults for a user with an unassigned gid
Summary: rpmbuild segfaults for a user with an unassigned gid
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-18 22:41 UTC by Lester Scofield
Modified: 2012-06-20 13:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 13:22:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lester Scofield 2006-07-18 22:41:30 UTC
Description of problem:
I has a user on a dev box who is managed by LDAP auth. The user's group id did
not exist in the local /etc/group file.  when doing an rpmbuild as this user,
and building an rpm from files owned by this non-existant group rpmbuild would
segfault right away.  Once the gid is added in /etc/group rpmbuild worked as
expected.

Version-Release number of selected component (if applicable):
rpm-build-4.3.3-13_nonptl

How reproducible:
Have not tried to reproduce, but I can give it a try.

Steps to Reproduce:
1. create user with a gid that is not used in /etc/group
2. build src rpm package as this user, so that all new files are owned by this
bad group
3. call rpmbuild 
  
Actual results:
rpmbuild segfaults

Expected results:
creation of an rpm

Additional info:

The user used to create the rpm did everything localy, i.e. in $HOME, not
/usr/src/redhat

Comment 1 Jeff Johnson 2006-07-24 01:59:44 UTC
Is nscd running? If not, try starting the daemon.

Adding the group to /etc/group is the very easy workaround, highly recommended.

Comment 2 Paul Nasrat 2006-09-20 10:08:19 UTC
Does nscd make this work?

Comment 3 Jiri Pallich 2012-06-20 13:22:57 UTC
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.


Note You need to log in before you can comment on or make changes to this bug.