Bug 199334 - cmirror removal attempt hangs and caused locking errors as well as a flood of console warnings
cmirror removal attempt hangs and caused locking errors as well as a flood of...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cmirror (Show other bugs)
4
All Linux
high Severity high
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 18:48 EDT by Corey Marthaler
Modified: 2010-04-27 10:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 10:56:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-07-18 18:48:31 EDT
Description of problem:
After about 60 or so loops of cmirror creation and deletion I hit this bug on
the link-128 cluster.

[root@link-08 ~]# while true
> do
> lvcreate  -L 1G -m 1 -n mirror1 mirror_1_2254
> sleep 4
> lvremove -f /dev/mirror_1_2254/mirror1
> done
  Logical volume "mirror1" created
  Logical volume "mirror1" successfully removed
  [...]
  Logical volume "mirror1" created
  Logical volume "mirror1" successfully removed
  Logical volume "mirror1" created
  Error locking on node link-08: Command timed out
  Error locking on node link-01: Command timed out
  Unable to deactivate logical volume "mirror1"


[root@link-08 ~]# dmsetup ls
mirror_1_2254-mirror1_mlog      (253, 2)
VolGroup00-LogVol01     (253, 1)
mirror_1_2254-mirror1_mimage_1  (253, 4)
VolGroup00-LogVol00     (253, 0)
mirror_1_2254-mirror1_mimage_0  (253, 3)

[root@link-08 ~]# lvs
[HANG]

Jul 18 11:42:39 link-08 kernel: device-mapper: Marked regions::
Jul 18 11:42:39 link-08 kernel: device-mapper:   513 - 2048
Jul 18 11:42:39 link-08 kernel: device-mapper:   Total = 1535
Jul 18 11:42:39 link-08 kernel: device-mapper: Out-of-sync regions::
Jul 18 11:42:39 link-08 kernel: device-mapper:   513 - 2048
Jul 18 11:42:39 link-08 kernel: device-mapper:   Total = 1535
Jul 18 11:42:39 link-08 kernel: device-mapper: Clean-up required due to new server
Jul 18 11:42:39 link-08 kernel: device-mapper:  - Wiping clear region list
Jul 18 11:42:39 link-08 kernel: device-mapper:  - 1 clear region requests wiped
Jul 18 11:42:39 link-08 kernel: device-mapper:  - Resending all mark region requests
Jul 18 11:42:39 link-08 kernel: device-mapper: Clean-up complete
Jul 18 11:42:39 link-08 kernel: device-mapper: Continuing request::
LRT_COMPLETE_RESYNC_WORK
Jul 18 11:42:44 link-08 kernel: device-mapper: A cluster mirror log member has left.
Jul 18 11:42:49 link-08 kernel: device-mapper: Cluster mirror log server is
shutting down.
Jul 18 11:43:03 link-08 dmeventd[6754]: Monitoring mirror device,
mirror_1_2254-mirror1 for events
Jul 18 11:43:08 link-08 kernel: device-mapper: A cluster mirror log member has left.
Jul 18 11:43:12 link-08 kernel: device-mapper: HEY!!! There are two matches for
eLA8WiFC
Jul 18 11:43:43 link-08 last message repeated 5207 times
Jul 18 11:44:44 link-08 last message repeated 10493 times
Jul 18 11:45:45 link-08 last message repeated 10494 times
Jul 18 11:46:46 link-08 last message repeated 10494 times
[...]


Version-Release number of selected component (if applicable):
[root@link-08 ~]# uname -ar
Linux link-08 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64
x86_64 GNU/Linux
[root@link-08 ~]# rpm -q cmirror
cmirror-1.0.1-0
[root@link-08 ~]# rpm -q cmirror-kernel
cmirror-kernel-2.6.9-10.2
[root@link-08 ~]# rpm -q lvm2
lvm2-2.02.06-6.0.RHEL4
[root@link-08 ~]# rpm -q lvm2-cluster
lvm2-cluster-2.02.06-6.0.RHEL4
[root@link-08 ~]# rpm -q device-mapper
device-mapper-1.02.07-4.0.RHEL4
Comment 1 Corey Marthaler 2006-11-22 13:33:17 EST
Marking this as verified. All current cmirror hangs are documented in bz 214517
and 214808.
Comment 3 Alasdair Kergon 2010-04-27 10:56:54 EDT
Assuming this VERIFIED fix got released.  Closing.
Reopen if it's not yet resolved.

Note You need to log in before you can comment on or make changes to this bug.