Bug 199343 - Anaconda [Errno 256] while attempting hard disk install ISO on IDE HD
Anaconda [Errno 256] while attempting hard disk install ISO on IDE HD
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Chris Lumens
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 20:54 EDT by Paul G. Mallasch
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 13:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.48 KB, text/plain)
2006-07-18 20:54 EDT, Paul G. Mallasch
no flags Details
syslog (9.34 KB, text/plain)
2006-07-18 20:55 EDT, Paul G. Mallasch
no flags Details
Directory tree of ISO image (1.24 KB, text/plain)
2006-07-21 18:47 EDT, Paul G. Mallasch
no flags Details

  None (edit)
Description Paul G. Mallasch 2006-07-18 20:54:38 EDT
Description of problem:
FC5 Hard disk install failed with Errno 256, "no mirror" available from a custom
built FC5 distro re-roll.

Version-Release number of selected component (if applicable):
anaconda-11.0.5-1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Headless blade P3 with 40 GB IDE HD
2. Script successfully partitions & formats hdc as ext3
3. Move ISO to partitioned HD on extended partition hdc5
4. Begin installation with serial console & selinux=0 on kernel line
5. Fails BEFORE tty2 is enabled so limited logging available
6. Failed with repodata/repomd.xml [Errno 256]
  
Actual results:
Unable to read package meta data. This may be due to a missing rpodata
directory. Please ensure that your install tree has been correctly generated.
failure: repodata/repoxmd.xml from anaconda: [Errno 256] No more mirrors to try.

Expected results:
Expected it to find the ISO images on the Hard Disk in directory listed in log.

Additional info:
Successful installation of custom distro using ISO on VMware virtual machine
using CD.
Also successful installation on other hardware (laptops) using CD.
Fails on blade computer BEFORE tty2 is enabled so attached anaconda.log & syslog
are captured by adding "rescue" to kernel line.
Checksums okay.
Able to loop mount ISO on hdc5 and check sha2sum files & permissions in
repodata/repomd.xml directory okay
Comment 1 Paul G. Mallasch 2006-07-18 20:54:38 EDT
Created attachment 132631 [details]
anaconda.log
Comment 2 Paul G. Mallasch 2006-07-18 20:55:55 EDT
Created attachment 132632 [details]
syslog
Comment 3 Jeremy Katz 2006-07-19 15:00:30 EDT
This means you haven't correctly created -- see
http://fedoraproject.org/wiki/AnacondaCustomization
Comment 4 Paul G. Mallasch 2006-07-21 18:47:18 EDT
Created attachment 132851 [details]
Directory tree of ISO image
Comment 5 Paul G. Mallasch 2006-07-21 18:51:21 EDT
Thanks Jeremy.  I've carefully walked my scripting and used another posting's
scripting which also uses Mr. Nasrat's Anaconda Customization outline, but both
return the same error.

I've attached a slightly snipped directory tree of my current ISO image mounted
with loop to illustrate the location of repodata/repomd.xml.

I'm curious as to why the CD installation would work fine, but not on HD...
Comment 6 Chris Lumens 2007-02-23 12:27:21 EST
Have you tried this lately?  I know there were various problems with hard drive
ISO install methods that could generate this sort of error message.  I've fixed
a variety of them over the past release or two, but there may still be more.  If
you could update this bug with the current status, I can take a look deeper into
it if things are still broken.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.