Bug 199351 - Crashing yumex via changing options on start
Crashing yumex via changing options on start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-18 21:54 EDT by James Burke
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 02:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Burke 2006-07-18 21:54:54 EDT
Description of problem:
Yumex crashes if one decides to change Repository options before it finished
updating headers/etc upon start.

Version-Release number of selected component (if applicable):
Name        : yumex                        Relocations: (not relocatable)
Version     : 0.99.16                           Vendor: Fedora Project
Release     : 1.0.fc5                       Build Date: Thu 06 Apr 2006 07:17:53
AM EDT


How reproducible:


Steps to Reproduce:
1. start yumex from an xterm box
2. Upon starting, progress bars on bottom indicate download/updating things--
While it's doing this, click on 'Repos' in left pane.
3. Now in repos dialog, change repos checkboxes and select 'Refresh'
  
Actual results:
Crashes 

Expected results:

Additional info:
I would get different crash reports. A routing is not being reset while using
obsolete variables-- I can tell this because one crash report says 'out of
range' for some tuple. I believe this shouldn't be too hard to fix. If one does
activity on any of the buttons, there should be a cancel dialog popup or there
should be a suspend/wait/reset states implemented so the variables set from the
Repos dialog box be reflected.
Comment 1 Tim Lauridsen 2006-07-19 02:25:32 EDT
Try to update to the latest stable yumex release 1.0.2.
You can change anything before metadata is loaded in the stable release.

Note You need to log in before you can comment on or make changes to this bug.