Bug 19937 - Word Perfect Office 2000 for Linux, FontTastic problem
Summary: Word Perfect Office 2000 for Linux, FontTastic problem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-27 18:38 UTC by David Smith
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-13 05:53:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Smith 2000-10-27 18:38:49 UTC
I'm reporting this here because I think 7.0 breaks something that works in
earlier versions of RedHat. When I run setup from the word perfect office
2000 for linux, I get the following two error messages (omitting irrelevant
stuff):

file /etc/init.d from install of fonttastic-glibc-2.1-2000.03.13.12.01-1
conflicts with file from package chkconfig-1.2.16-1
file /etc/init.d from install of fonttastic-glibc-2.1-2000.03.13.12.01-1
conflicts with file from package initscripts-5.49-1

as a result, word perfect's fonttastic font server fails to start properly.

sh: /etc/rc.d/init.d/fonttastic: No such file or directory

Comment 1 Bill Nottingham 2000-10-27 22:52:23 UTC
Exactly what does that package think /etc/init.d should
be?  It looks like the fontastic thing is a buggy package.

Comment 2 Bill Nottingham 2001-07-31 06:22:20 UTC
closing, lack of input.

Comment 3 Raul Dias 2002-08-07 22:33:22 UTC
Hi,

I am not the reporter, but the problem is with RPM.
(ok fonttastic is a buggy package, but it is unlikely that Corel will update it).

RPM allows packages to own the same dir.
However it does not allow packages to own the same file (for obvious reasons).

/etc/init.d is a link to /etc/rc.d/init.d

However RPM (or cpio) sees it as a regular file and outputs the conflict.

The correct way to handle this would be to make RPM threat symbolic links
point to directories as a directory too.

This way would allow broken packages (as fonttastic) to install.

I am writing this here not to change RPM so that broken packages could be 
created, but because there are some situations where this behaviour is desired
in RPM.

A common case is when you change a directory to a symlink to another dir in a
new package.
Usually the symlink is to keep compatibility with other packages that does not
"know" about the new behaviour and looks in the old dir.


Note You need to log in before you can comment on or make changes to this bug.