Bug 199389 - no help about shortcuts
no help about shortcuts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: FutureFeature, i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 03:28 EDT by A S Alam
Modified: 2013-07-02 20:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.5.8-3.fc9
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-28 18:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (4.57 KB, application/octet-stream)
2008-03-07 02:10 EST, Caius Chance
no flags Details
patch (4.57 KB, patch)
2008-03-07 02:10 EST, Caius Chance
no flags Details | Diff
updated spec (8.98 KB, application/octet-stream)
2008-03-07 02:10 EST, Caius Chance
no flags Details
patch (5.50 KB, text/plain)
2008-04-21 02:43 EDT, Caius Chance
no flags Details
update patch with gettext macro'ed (5.54 KB, patch)
2008-04-21 03:02 EDT, Caius Chance
no flags Details | Diff
spec (8.97 KB, text/plain)
2008-04-21 03:02 EDT, Caius Chance
no flags Details
spec patch (1008 bytes, patch)
2008-04-21 19:33 EDT, Caius Chance
no flags Details | Diff
Removed patch rename, version and changelog correction only. (216 bytes, patch)
2008-06-16 20:58 EDT, Caius Chance
no flags Details | Diff
Cleaned up patch. (4.13 KB, patch)
2008-06-22 21:04 EDT, Caius Chance
no flags Details | Diff

  None (edit)
Description A S Alam 2006-07-19 03:28:44 EDT
Description of problem:
during using Hindi layout, tried to search help about shortcuts
-How to change En-hi and hi-En  (Ctrl-Space)
-How to change layouts (hi-Inscript->hi-Phonetci)  {Ctrl+Shift)

Version-Release number of selected component (if applicable):
scim-1.4.4-24.fc6

How reproducible:


Steps to Reproduce:
1. make SCIM active
2. select hindi-inscript
3. goto Help (press Help button)
  
Actual results:
No Information about shortcut

Expected results:
Information should be there, so that user can effectively user Shortcuts

Additional info:
ja_JP Anthy is good example
Comment 1 Jens Petersen 2006-07-24 02:16:10 EDT
Hmm, those settings are user configurable in scim-setup,
but I suppose it might be useful to have the trigger hotkey at least appear
at the top of the help dialog.  BTW the Ctrl+Shift (next/previous factory
hotkeys are only defined by default for Chinese users for fc6).

scim-anthy doesn't provide any information about general scim hotkeys,
only anthy specific bindings.
Comment 2 Peng Huang 2008-03-03 03:45:58 EST
I agree with Jens and put this bug to wontfix.
(In reply to comment #1)
> Hmm, those settings are user configurable in scim-setup,
> but I suppose it might be useful to have the trigger hotkey at least appear
> at the top of the help dialog.  BTW the Ctrl+Shift (next/previous factory
> hotkeys are only defined by default for Chinese users for fc6).
> 
> scim-anthy doesn't provide any information about general scim hotkeys,
> only anthy specific bindings.

Comment 3 Jens Petersen 2008-03-04 05:29:23 EST
Well I think it would be good display some of the global hotkeys in the help.
It shouldn't be too hard to add.
Comment 4 Peng Huang 2008-03-04 20:56:26 EST
What's kind of global hotkeys? 
The hotkeys can be changed by user self. I think global hotkeys should not be
displayed in Engines help. Engine help should only contain hotkeys in Engine,
not global.
Comment 5 Jens Petersen 2008-03-04 23:17:30 EST
Yep it should not be hardcoded, scim should display the current hotkey bindings
at the top of the help text IMHO.
Comment 6 Peng Huang 2008-03-04 23:39:13 EST
One action may has null hotkey, one hotkey or many hotkeys. How about just show
the fist hotkey for one action?
Comment 7 Caius Chance 2008-03-07 02:10:00 EST
Created attachment 297144 [details]
patch
Comment 8 Caius Chance 2008-03-07 02:10:03 EST
Created attachment 297145 [details]
patch
Comment 9 Caius Chance 2008-03-07 02:10:35 EST
Created attachment 297146 [details]
updated spec
Comment 10 Peng Huang 2008-03-07 02:31:46 EST
Found the help string is from scim-bridge. 
It has been fixed in scim-bridge-0.4.15-2.
Thanks Caius Chance.
Comment 11 Jens Petersen 2008-03-09 19:33:47 EDT
I don't really understand why the help comes from scim-bridge:
really it should not depend on what immodule or XIM is used
since the hotkeys are global and (should be) independent of
the immodule.  So this looks like a design issue in SCIM.

Currently it seems we will get different help from im-scim, scim-bridge,
and scim-qtimm (maybe im-scim and XIM are the same?).
Comment 12 Caius Chance 2008-03-09 19:56:19 EDT
How's upstream thinking?
Comment 13 Peng Huang 2008-03-09 22:30:33 EDT
(In reply to comment #11)
> I don't really understand why the help comes from scim-bridge:
> really it should not depend on what immodule or XIM is used
> since the hotkeys are global and (should be) independent of
> the immodule.  So this looks like a design issue in SCIM.
> 
> Currently it seems we will get different help from im-scim, scim-bridge,
> and scim-qtimm (maybe im-scim and XIM are the same?).

I found the help string is not from im module. It is from scim-bridge-agent when
using scim-bridge. When just using scim, the help string is from scim-panel-gtk.

Comment 14 Jens Petersen 2008-03-10 02:27:30 EDT
> I found the help string is not from im module. It is from scim-bridge-agent when
> using scim-bridge. When just using scim, the help string is from scim-panel-gtk.

Ok, I see thanks.

Currently I now see:

"""
Smart Common Input Method platform 1.4.6      <--  note wrong version!! (should
be scim-bridge version I guess or something like that)
(C) 2002-2005 James Su <suzhe@tsinghua.org.cn>    <-- the date is out of date too

Global Hotkeys:
                         <-- better not to have a newline IMHO to save space
Trigger: Zenkaku_Hankaku,Alt+grave,Control+space   <-- probably most users don't
know what "trigger" means
                         <-- better no newline again
Turn on: Unable to be loaded.              <-- this should say "undefined"
                         <-- again can drop empty line
Turn off: Unable to be loaded.             <-- should be changed
                         <-- no newline
Next input method:

Previous input method:

<IME help.....>
"""

I think it is better not to mention undefined/empty hotkeys anyway
(trigger is the most important one anyway).

Also it would be better to remove the "Smart Common Input Method"
frame around the help text widget - it looks strange.
Comment 15 Jens Petersen 2008-03-10 03:41:00 EDT
> Also it would be better to remove the "Smart Common Input Method"
> frame around the help text widget - it looks strange.

Doing that in scim-1.4.7-17.fc9.
Comment 16 Caius Chance 2008-04-21 02:43:05 EDT
Created attachment 303112 [details]
patch

Excessive newlines are removed.

Undefined hot keys will not be shown.
Comment 17 Caius Chance 2008-04-21 03:02:18 EDT
Created attachment 303115 [details]
update patch with gettext macro'ed
Comment 18 Caius Chance 2008-04-21 03:02:41 EDT
Created attachment 303116 [details]
spec
Comment 19 Peng Huang 2008-04-21 04:05:13 EDT
Hi cchance,
I found two little problems. One is that you modified the header of help text. I
think you should not do it. The helper text is for scim, not for scim-bridge. So
I you should remain the origin header.
The another is the spec file is not based on the newest version spec file in cvs.
Comment 20 Caius Chance 2008-04-21 19:24:19 EDT
(In reply to comment #19)
> I found two little problems. One is that you modified the header of help text. I
> think you should not do it. The helper text is for scim, not for scim-bridge. So
> I you should remain the origin header.

This is based on the patch suggested my jensp. I'll ask him about this.

> The another is the spec file is not based on the newest version spec file in cvs.
> 

You could ignore the spec attachment if so. The only change is addition of the
patch, release number, and changelog.
Comment 21 Caius Chance 2008-04-21 19:33:37 EDT
Created attachment 303231 [details]
spec patch
Comment 22 Jens Petersen 2008-04-23 02:40:53 EDT
(No need to rename the patch BTW, we can just update the current patch.)

(In reply to comment #19)
> One is that you modified the header of help text. I
> think you should not do it. The helper text is for scim, not for scim-bridge. So
> I you should remain the origin header.

Ok lets include both copyright for scim and scim-bridge, but not mention the
scim version in the text.  I think it is good to show which immodule is being
used too.

Also as I suggested to Caius, I still feel the patch should be possible just
on scim-bridge-agent-imcontext.cpp, I am still unclear why it has to be
split over scim-bridge-agent.cpp.
Comment 23 Caius Chance 2008-06-16 20:58:14 EDT
Created attachment 309559 [details]
Removed patch rename, version and changelog correction only.
Comment 24 Caius Chance 2008-06-17 01:10:07 EDT
(In reply to comment #22)
> Also as I suggested to Caius, I still feel the patch should be possible just
> on scim-bridge-agent-imcontext.cpp, I am still unclear why it has to be
> split over scim-bridge-agent.cpp.

To display the hotkeys used in helper, we need info from config. However,
scim-bridge-agent-imcontext.cpp which is responsible to display helper doesn't
have any code currently accessing data in config.

Using scim-bridge-agent.cpp to 'feed' hotkey info to
scim-bridge-agent-imcontext.cpp is the most efficient way to achieve the
objective. Otherwise, we need to duplicate large amount of config info
preparation code in scim-bridge-agent-imcontext.cpp just to have maximum of 5
used hotkeys.

The extra work doesn't include extra code analysis, testing and higher potential
impact to the quality, too.
Comment 25 Caius Chance 2008-06-22 21:04:10 EDT
Created attachment 310009 [details]
Cleaned up patch.

Hotkey settings are listed single newlines.
Author info, version, dates are fixed.
Removed unnecessary indentation changes in patch file.
Comment 26 Fedora Update System 2008-06-23 21:00:08 EDT
scim-tables-0.5.8-3.fc9 has been submitted as an update for Fedora 9
Comment 27 Fedora Update System 2008-06-28 18:16:50 EDT
scim-tables-0.5.8-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Jens Petersen 2008-06-29 19:39:48 EDT
Comment 26 and comment 27 refer to bug 438662

Note You need to log in before you can comment on or make changes to this bug.