Bug 1994037 - RHV resources referenced by ID in CRs cause "Provider not found" error
Summary: RHV resources referenced by ID in CRs cause "Provider not found" error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: Inventory
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.2.0
Assignee: Jeff Ortel
QA Contact: Amos Mastbaum
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks: 1995408
TreeView+ depends on / blocked
 
Reported: 2021-08-16 14:39 UTC by Jeff Ortel
Modified: 2021-12-09 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1995408 (view as bug list)
Environment:
Last Closed: 2021-12-09 19:20:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github konveyor forklift-controller pull 338 0 None None None 2021-08-16 14:40:48 UTC
Red Hat Product Errata RHEA-2021:5066 0 None None None 2021-12-09 19:20:54 UTC

Description Jeff Ortel 2021-08-16 14:39:02 UTC
Description of problem:

RHV resources referenced on CRs by ID can be confused with provider not found in the inventory.  For example: on the network map CR, if the ID (instead of Name) value is "fast/network123", this will result in the expected 404 (NotFound).  However, because of the X-Provider reply header is missing, the controller will interpret as - The provider has not been added to the inventory.

As a result, the CR is never fully reconciled.

Affects:
- Plan CR
- NetworkMap CR
- StorageMap CR
- Host CR

Version-Release number of selected component (if applicable):

2.1.


How reproducible:

Always.


Steps to Reproduce:
1. Create a CR with the ref ID as described in the description.
2. Note: the CR: Generation and ObservedGeneration never match and the continuous reQ=3 in the controller log.
3.

Actual results:

CR never get reconciled.


Expected results:

CR is reconciled.


Additional info:

Comment 1 Fabien Dupont 2021-08-16 16:38:11 UTC
This is kind of an edge case only when malforming the id string in the CR through the API.
Targeting to MTV 2.2.0.

Comment 2 Fabien Dupont 2021-10-11 09:06:34 UTC
Please verify with mtv-operator-bundle-2.2.0-41 / iib:122011, or later.

Comment 3 Amos Mastbaum 2021-10-17 08:09:16 UTC
verified all CRs (new/edit)
verified reconsolidation ended message in the console log
verified validation status condition
MTV 2.2.0-50

Comment 6 errata-xmlrpc 2021-12-09 19:20:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (MTV 2.2.0 Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:5066


Note You need to log in before you can comment on or make changes to this bug.