This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 199414 - Xen network-bridge: fails to start bridge because module not loaded
Xen network-bridge: fails to start bridge because module not loaded
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 09:44 EDT by Mark McLoughlin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 11:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xen-network-iptables-bridge.patch (553 bytes, patch)
2006-07-19 09:44 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2006-07-19 09:44:36 EDT
Trying to start domU with latest xen, I'm seeing this in /var/log/xend.log:

  VmError: Device 0 (vif) could not be connected. Hotplug scripts not working.

With such a helpful error message, the problem was obvious of course :-)


Issue is that the network-bridge script has been changed around a bit, and it
was failing with:

  error: "net.bridge.bridge-nf-call-arptables" is an unknown key

The bridge module wasn't being loaded.

Seems that brctl was previously being run before this point, and the ioctl is
uses would cause the bridge module to be loaded.

Attaching a fixed version of xen-network-iptables-bridge.patch which tweaks the
kernel params after starting the bridge.
Comment 1 Mark McLoughlin 2006-07-19 09:44:37 EDT
Created attachment 132682 [details]
xen-network-iptables-bridge.patch
Comment 2 Mark McLoughlin 2006-07-19 11:36:54 EDT
* Wed Jul 19 2006 Mark McLoughlin <markmc@redhat.com> 3.0.2-16
- Fix network-bridge error (#199414)

Note You need to log in before you can comment on or make changes to this bug.