Bug 1994196 - Remove /usr/bin/packer symbolic link
Summary: Remove /usr/bin/packer symbolic link
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cracklib
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-17 02:54 UTC by Weston Schmidt
Modified: 2021-09-24 20:11 UTC (History)
5 users (show)

Fixed In Version: cracklib-2.9.6-27.fc36 cracklib-2.9.6-27.fc34 cracklib-2.9.6-27.fc33 cracklib-2.9.6-27.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 21:05:15 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker FC-265 0 None None None 2021-08-18 02:51:56 UTC

Description Weston Schmidt 2021-08-17 02:54:16 UTC
Description of problem:
The symbolic link `/usr/bin/packer` conflicts with the popular Hashicorp product of the same name.  The executable is already available via `/usr/sbin/cracklib-packer`.  By removing this symbolic link the community makes using the other product much easier.

Simply removing these two lines will do the trick:
https://src.fedoraproject.org/rpms/cracklib/blob/rawhide/f/cracklib.spec#_122
https://src.fedoraproject.org/rpms/cracklib/blob/rawhide/f/cracklib.spec#_176

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora with Gnome Desktop
2. Install Hashicorp Packer:
sudo dnf install -y dnf-plugins-core
sudo dnf config-manager --add-repo https://rpm.releases.hashicorp.com/fedora/hashicorp.repo
sudo dnf -y install packer

3. Run `packer` without qualifications.  The cracklib-packer is executed because it is located in /usr/sbin/packer vs the /usr/bin/packer you just installed.

Additional info:

A few details make this something to consider changing.

1. You can't remove the offending `cracklib` package because GNOME depends on it.
2. This is a symbolic link to a more descriptively named `cracklib-packer`
3. Upstream does not require this, it is only a Fedora packaging convention.

There are workarounds, but they are also annoying and brittle.

Comment 1 Paul Wouters 2021-08-18 02:51:03 UTC
It is unfortunate. And I don't like making a change that breaks backwards compatibility. But in this case I think it is better to break it now than later when/if this package gets info fedora.

It also seems that cracklib as dependency mostly comes in for libpwquality, and that library surely does not call the packer binary


paul@bofh:~$ grep packer /usr/lib64/libpwquality.so.1
paul@bofh:~$ grep packer /usr/bin/pwmake /usr/bin/pwscore 
paul@bofh:~$ grep packer /etc/security/pwquality.conf

If no one objects in the next few days, I'll make the change.

Comment 2 Fedora Update System 2021-08-30 21:02:56 UTC
FEDORA-2021-66e64152af has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-66e64152af

Comment 3 Fedora Update System 2021-08-30 21:05:15 UTC
FEDORA-2021-66e64152af has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2021-08-30 21:36:55 UTC
FEDORA-2021-f579afbe46 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f579afbe46

Comment 5 Fedora Update System 2021-08-30 21:49:10 UTC
FEDORA-2021-48813025be has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-48813025be

Comment 6 Fedora Update System 2021-08-31 07:35:41 UTC
FEDORA-2021-dac2bec579 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-dac2bec579

Comment 7 Fedora Update System 2021-08-31 17:57:08 UTC
FEDORA-2021-f579afbe46 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f579afbe46`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f579afbe46

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-08-31 22:04:36 UTC
FEDORA-2021-dac2bec579 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-dac2bec579`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-dac2bec579

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-08-31 22:53:05 UTC
FEDORA-2021-48813025be has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-48813025be`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-48813025be

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2021-09-08 15:06:06 UTC
FEDORA-2021-48813025be has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Fedora Update System 2021-09-15 18:19:44 UTC
FEDORA-2021-dac2bec579 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2021-09-24 20:11:51 UTC
FEDORA-2021-f579afbe46 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.