This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 199492 - abbrev tag and line wrapping
abbrev tag and line wrapping
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 16:54 EDT by Charles Curley
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: firefox-2.0.0.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 09:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Curley 2006-07-19 16:54:26 EDT
Description of problem:

If the title attribute of the abbrev tag contains a line ending and then more
text, the text after the line ending does not show up in the "tool tip" when you
mouse over.

I expect that this is an upstream bug.

Version-Release number of selected component (if applicable):

firefox-1.5.0.4-1.2.fc5

How reproducible:

consistent reproduction.

Steps to Reproduce:

I found the problem looking at http://www.fedorafaq.org/, so I'll use the source
from their web page for this.

1. Prepare a web page which complies with a suitable standard. I used utf-8 and
HTML 4.01. Include the following text, exactly as shown. Note the trailing space
after "May".

<p class="Warning">
  <img src="img/warning.png" alt="" />
  NOTE: This is not an official form of support. This is not an 
  official service of Red Hat. These things may 
  solve your worst nightmare, or they may <em>eat all of the cheese</em>
  in your house. I make no guarantees. <abbr title="Your Milage May 
  Vary">YMMV</abbr>.

</p>

2. display the page. Mouse over the YMMV abbr tag. Observe the contents of the
"tool tip".


3. Merge the "Vary..." line to the end of the previous line. Redisplay. Mouse
over again. Observe the contents of the "tool tip".
  
Actual results:

For step 2, I see "Your Milage May ".

Expected results:

For step 2, I expect to see the text "Your Milage May Vary".

Additional info:

Please check other tags such as acronym that display an attribute similarly.

Work-around: see to it that attributes of tags do not cross line endings.
Comment 1 Matěj Cepl 2007-07-18 13:32:36 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 2 Charles Curley 2007-07-18 15:22:56 EDT
It seems to be fixed, at least for the test case above. FC7, firefox-2.0.0.4-2.fc7. As far as I am concerned, feel free to mark it Closed and Fixed.

Note You need to log in before you can comment on or make changes to this bug.