Bug 199496 - authconfig should use /etc/pki/tls/certs instead of /etc/openldap/cacerts
Summary: authconfig should use /etc/pki/tls/certs instead of /etc/openldap/cacerts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-19 21:10 UTC by Joachim Selke
Modified: 2008-06-06 12:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-06 12:22:21 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Selke 2006-07-19 21:10:56 UTC
Description of problem:
When using LDAP via a TLS encrypted connection a CA certificate is needed. By
default, authconfig uses /etc/openldap/cacerts for storing those certs.

Since FC4 digital certificates are stored centralised in /etc/pki, and TLS
certificates should be put in /etc/pki/tls/certs.

authconfig should use this directory as default for the above LDAP CA certs.


Version-Release number of selected component (if applicable):
authconfig-5.3.2-1

Comment 1 Tomas Mraz 2006-07-20 10:08:01 UTC
This should be rather /etc/pki/ldap/cacerts directory.


Comment 2 Bug Zapper 2008-04-03 17:49:05 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 3 Bug Zapper 2008-05-14 02:14:48 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Tomas Mraz 2008-06-06 12:22:21 UTC
WONTFIX for now as it doesn't make sense to me to break existing setups for
cosmetic change.


Note You need to log in before you can comment on or make changes to this bug.