This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 199504 - icu4j plugins should be built in the icu4j package
icu4j plugins should be built in the icu4j package
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On: 199592
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 19:15 EDT by David Walluck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 03:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch to icu4j/devel/icu4j.spec (3.66 KB, patch)
2007-01-05 15:40 EST, Jeff Johnston
no flags Details | Diff
Proposed patch to icu4j/devel/icu4j.spec revised. (4.29 KB, patch)
2007-01-08 13:51 EST, Jeff Johnston
no flags Details | Diff
Merged spec file, ready to build (already tested on non-official mock) (8.70 KB, application/octet-stream)
2007-01-22 18:35 EST, Fernando Nasser
no flags Details

  None (edit)
Description David Walluck 2006-07-19 19:15:29 EDT
I think we want something like the following.

rm baseLocation/plugins/com.ibm.icu.base_3.4.4.1.jar
ln -s %{_javadir}/icu4j.jar baseLocation/plugins/com.ibm.icu.base_3.4.4.1.jar
rm baseLocation/plugins/com.ibm.icu_3.4.4.1.jar
ln -s %{_javadir}/icu4j.jar baseLocation/plugins/com.ibm.icu_3.4.4.1.jar
rm features/org.eclipse.platform.launchers/bin/startup.jar
rm plugins/org.eclipse.swt.tools/swttools.jar
rm plugins/org.eclipse.swt.win32.win32.x86/swt.jar
rm plugins/org.eclipse.swt/extra_jars/exceptions.jar

For icu4j, I tried upstream release 3.4.4 (packaged as a rpm based on an old
JPackage version of icuj) and it didn't appear to work. The difference between
com.ibm.icu.base and com.ibm.icu seem to be the number of classes, where base is
some subset of the full version. The `diff' between the included jar and
upstream 3.4.4 jar is:

@@ -1,9 +1,5 @@
 META-INF/
 META-INF/MANIFEST.MF
-about.html
-about_files/
-about_files/license.html
-about_files/ucdterms.txt
 com/
 com/ibm/
 com/ibm/icu/
@@ -33,6 +29,7 @@
 com/ibm/icu/impl/CollectionUtilities$MultiComparator.class
 com/ibm/icu/impl/CollectionUtilities$ObjectMatcher.class
 com/ibm/icu/impl/CollectionUtilities$PrefixIterator.class
+com/ibm/icu/impl/CollectionUtilities$RegexIterator.class
 com/ibm/icu/impl/CollectionUtilities.class
 com/ibm/icu/impl/ICUBinary$Authenticate.class
 com/ibm/icu/impl/ICUBinary.class
@@ -1062,4 +1059,3 @@
 com/ibm/icu/util/ValueIterator$Element.class
 com/ibm/icu/util/ValueIterator.class
 com/ibm/icu/util/VersionInfo.class
-plugin.properties
Comment 1 Ben Konrath 2006-11-22 16:58:48 EST
We currently build the icu4j 3.4.5 in the eclipse srpm. We are going to move
this build from the the eclipse srpm to the icu4j package and make an
icu4j-eclipse subpackage. The build logic for the icu4j-eclipse subpackage is
currently in the eclispe spec file from FC-6. Any help here would be
appreciated. Feel free to ping me if you have any questions. Thanks. 
Comment 2 David Walluck 2006-11-22 20:58:39 EST
I have an icu4j 3.4.5 spec. Would this be useful? I can attach it.
Comment 3 Ben Konrath 2006-11-23 02:01:04 EST
Yeah, that would be useful if we can't get it any place else. Thanks.
Comment 4 Ben Konrath 2006-11-30 09:49:47 EST
Re-assigning to Jeff as he will be doing this work.
Comment 5 Jeff Johnston 2007-01-05 15:40:03 EST
Created attachment 144927 [details]
Proposed patch to icu4j/devel/icu4j.spec
Comment 6 Jeff Johnston 2007-01-05 16:26:44 EST
I need to look at the patch some more.  The src.zip file is not being generated
for com.ibm.icu.source plugin.
Comment 7 Jeff Johnston 2007-01-08 13:52:00 EST
Created attachment 145093 [details]
Proposed patch to icu4j/devel/icu4j.spec revised.
Comment 8 Jeff Johnston 2007-01-08 13:56:09 EST
Assigning to Fernando to review proposed spec patch.
Comment 9 Fernando Nasser 2007-01-22 16:04:43 EST
Working on it....
Comment 10 Fernando Nasser 2007-01-22 18:35:27 EST
Created attachment 146254 [details]
Merged spec file, ready to build (already tested on non-official mock)
Comment 11 Fernando Nasser 2007-01-22 18:42:24 EST
OK guys, I've merged this with upstream, built and uploaded there, built and
uploaded on the Toronto office FC7 mock.  RPMs at /home/fnasser/icu4j (for x86_64)

However, when I've tried to build on Brew I've got:

546290 build (dist-fc7, devel:icu4j-3_4_5-2jpp_1): open (btest1.z900.redhat.com)
-> FAILED: BuildError: package icu4j not in list for tag dist-fc7
  0 free  0 open  1 done  1 failed

So I guess icu4j never really made it to Fedora Core.  So someone would have to
suggest it as a new package.  Can someone who know the arguments for that
propose it through the "New Package Process"?  I will take care of any changes
required by the review process.  As test1 is tomorrow, this is kind of urgent.


Comment 12 Andrew Overholt 2007-01-22 21:01:57 EST
icu4j has never been in Fedora, you are correct.  Please submit it for review here:

http://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Fedora%20Core&format=core-review

I can do the review if no one else is free.  I needs to go into Core because it
is needed by Eclipse which is in Core.
Comment 13 Fernando Nasser 2007-01-23 09:00:29 EST
I'd rather we do the opposite.  I prefer to do the review as we will be doing it
for 100+ packages anyway.  And I'd rather someone else from outside our groups
asking for it.  We are already asking for 90+ maven-related dependencies ;-)
Comment 14 Andrew Overholt 2007-01-23 09:08:42 EST
(In reply to comment #13)
> I'd rather we do the opposite.  I prefer to do the review as we will be doing it
> for 100+ packages anyway.  And I'd rather someone else from outside our groups
> asking for it.  We are already asking for 90+ maven-related dependencies ;-)

I'm confused.  The package *must* go through the submission process via the link
I submitted.  We can always ask someone else to do the review, but it must be
submitted there first.
Comment 15 Fernando Nasser 2007-01-23 09:10:55 EST
Yes, that is what I am saying: _you_ propose the package for inclusion and we
take care of any fixes, builds etc. required by the reviwers.
Comment 16 David Walluck 2007-03-10 16:05:55 EST
Just for reference, here is my spec for icu4j 3.4.5:

http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/icu4j/current/SPECS/icu4j.spec?revision=74076&view=markup
Comment 17 Ben Konrath 2007-06-07 03:07:15 EDT
Closing this bug because it is not relevant anymore - the eclipse package in F7
includes a copy of the icu4j eclipse package. I'll try to sort this out for F8.

Note You need to log in before you can comment on or make changes to this bug.