Bug 199505 - grub fails to install
grub fails to install
Status: CLOSED DUPLICATE of bug 170407
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-07-19 19:23 EDT by Peter Quiring
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 23:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/boot/grub/device.map (63 bytes, text/plain)
2006-07-19 20:40 EDT, Peter Quiring
no flags Details
/var/log/anaconda.log (49.51 KB, application/octet-stream)
2006-07-19 20:40 EDT, Peter Quiring
no flags Details
/var/log/anaconda.syslog (86.12 KB, application/octet-stream)
2006-07-19 20:41 EDT, Peter Quiring
no flags Details
/var/log/anaconda.xlog (51.41 KB, application/octet-stream)
2006-07-19 20:41 EDT, Peter Quiring
no flags Details
alternate device.map (82 bytes, text/plain)
2006-09-22 12:21 EDT, Peter Quiring
no flags Details

  None (edit)
Description Peter Quiring 2006-07-19 19:23:28 EDT
Description of problem:  Aftering installing on hdb the install phase has failed
to install the grub boot sector on hda.  No errors encountered during install
phase. (note : hda = WinXP 100% NTFS, hdb = 100% free space).  I tried to boot
into rescue mode and try the "grub-install /dev/hda" after running "chroot
/mnt/sysimage" but I get an error message "/dev/hdb1 does not have a
corresponding BIOS drive number".


Version-Release number of selected component (if applicable):


How reproducible:Always (tried twice)


Steps to Reproduce:
1.Boot from DVD on USB-DVD-ROM
2.Allow anaconda to perform auto partitioning on free space.
3.Install Fedora Core (no error messages)
4.Reboot
5.Still booting into WinXP (no grub)
  
Actual results:Boots into XP boot manager.


Expected results:Boot into grub manager.


Additional info:I have saved a copy of the MBR from hda when I use to have FC5
installed on hda (hda was partitioned then).  Could I just paste this MBR back
into hda and will grub be "smart" enough to look for /boot on hdb???  Or is
there config info saved in the grub master boot sector for where to look for /boot?
Comment 1 Jeremy Katz 2006-07-19 20:16:58 EDT
Can you provide the /boot/grub/device.map as well as /var/log/anaconda*
Comment 2 Peter Quiring 2006-07-19 20:40:13 EDT
Created attachment 132714 [details]
/boot/grub/device.map

Interesting to note that hdb is NOT in this map file.
Comment 3 Peter Quiring 2006-07-19 20:40:38 EDT
Created attachment 132715 [details]
/var/log/anaconda.log
Comment 4 Peter Quiring 2006-07-19 20:41:17 EDT
Created attachment 132716 [details]
/var/log/anaconda.syslog
Comment 5 Peter Quiring 2006-07-19 20:41:54 EDT
Created attachment 132717 [details]
/var/log/anaconda.xlog
Comment 6 Peter Quiring 2006-07-19 20:44:45 EDT
Those are the requested log files.  Hope they help.

PS. I tried to copy the MBR from a previous FC5 install as I asked about in the
additional info -> didn't work -> just get a blank screen on bootup.
Comment 7 Peter Quiring 2006-07-19 21:21:39 EDT
Got it working. Looks like that device.map was not setup correctly.

1) I switched the drives (master <-> slave)
2) run linux rescue mode
3) edited device.map and added "(hd1)  /dev/hdb"
4) run "grub-install /dev/hdb" (note that I use hdb here since I switched the
drives)
5) switched the drives back

Steps 1 & 5 were probably not needed but I was trying stuff till I got it working.
Looks like the grub MBR is specific to install after all.
Comment 8 Peter Quiring 2006-07-19 21:55:53 EDT
FYI : I tried to run grub-install again without switching the drives and it
works.  So steps 1 & 5 were not needed in my fix posted earlier.  The problem is
definitely the device.map, but why?
Comment 9 Jeremy Katz 2006-07-20 17:54:21 EDT
Hrmm... we might have broken writing out things for multiple drives, although
the code seems fine from inspection
Comment 10 Peter Quiring 2006-07-20 20:18:06 EDT
Well... I tried to install FC5 and I get the same results.  So this is not a
regression.  I've never tried this current hardware config before with Fedora. 
I use to just re-partition my main drive since I was using FAT32 and it was easy
to resize, but now I use NTFS (faster) so I decided to pop in a smaller drive
and make it the slave to use for Fedora.
I'll try other things and keep you posted.
Could be just some sort of hardware compatibility issue.  
Comment 11 Peter Jones 2006-07-27 17:25:34 EDT
This probably just means we can't detect which one is bootable, and you need to
change the disk order on the "advanced bootloader options" screen.  Can you try
that?
Comment 12 Peter Quiring 2006-07-29 14:57:36 EDT
I tried that, no change.  In the "advanced bootloader options" everything looks
fine.  By default it shows:
  /dev/hda (MBR) (selected)
  /dev/hdb1
If I change the order of the drives it shows:
  /dev/hdb (MBR) (selected)
  /dev/hdb1
which doesn't make any sense.
The device.map isn't getting generated properly for grub-install.
Comment 13 Peter Jones 2006-09-22 10:20:42 EDT
The second of those (which you say doesn't make sense) appears to be correct -
have you tried it to see what happens?
Comment 14 Peter Quiring 2006-09-22 12:21:34 EDT
Created attachment 136949 [details]
alternate device.map
Comment 15 Peter Quiring 2006-09-22 12:24:14 EDT
As your can in this device.map when I switch the drive order, it has both drives
listed in there, but there order is reversed as expected.
I'm still booting directly into WinXP, so anaconda must have installed the MBR
on hdb as expected in this case.
Comment 16 Samuel Sieb 2006-11-04 14:27:17 EST
Did you use the default partitioning with LVM?  This may be a duplicate of bug
170407.
Comment 17 Peter Quiring 2006-11-04 14:49:37 EST
Yes, Bug 170407 seems similar.
Comment 18 Matthew Miller 2007-04-06 14:26:08 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 19 Samuel Sieb 2007-04-06 22:53:24 EDT
I would change the version if I could, but I can't.  This is almost certainly a
duplicate of bug 170407, but that one has FC4 as the version.
Comment 20 Matthew Miller 2007-04-06 23:58:33 EDT
Thanks. I'll mark this as a dupe and update that one.

*** This bug has been marked as a duplicate of 170407 ***

Note You need to log in before you can comment on or make changes to this bug.