Bug 199518 - Firstboot fails to start
Firstboot fails to start
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Depends On:
  Show dependency treegraph
Reported: 2006-07-19 23:05 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-24 10:19:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2006-07-19 23:05:24 EDT
Description of problem:
Firstboot fails to start in graphical mode and fails to start text mode.

Version-Release number of selected component (if applicable):

How reproducible:
not checked

Steps to Reproduce:
1. install using boot.iso and NFS from local repository (rawhide 2007-07-19)
2. unselect RHGB in software selection
3. install and reboot
Actual results:
Firstboot fails to start with default VESA config on several attempts
does not attempt firstboot-tui
/tmp/firstboot-crash.log contains
|Traceback (most recent call last):
|  File "/usr/sbin/firstboot", line 111, in ?
|    RaiseRuntimeError, "Could not start any firstboot interface"
|RuntimeError: Could not start any firstboot interface

Expected results:
even without RHGB, firstboot should start or fall back to the TUI

Additional info:

work1.private testbed machine: Celeron (Coppermine) @ 600MHz   256MB RAW
  MSI mobo based on VIA chipset
  Trident Cyberblade/i1 on mobo    RTL-8139 NIC on mobo
Comment 1 Chris Lumens 2006-07-20 10:30:19 EDT
Are there any X logs in /tmp?  If so, please attach them to this bug so we can
figure out why X is not starting.  For firstboot, it probably should boot into
the text interface if the graphical one does fail to start.  Thanks for the
Comment 2 G.Wolfe Woodbury 2006-07-22 22:58:42 EDT
With today's rawhide (2006-07-22) I could not reproduce this bug.

I unchecked RHGB as usual and installed.  The only problem was that I had to
"move aside" /etc/X11/xinit/xinitrc.d/localuser.sh (as mentioned as a cure for a
gdm bug in the test list.)

Firstboot came up and worked with X-windows just fine.  It did dump the
soundcard module and the display module is currently disabled, so everything
mostly worked.

I'd suggest closing this off with a "RAWHIDE" disposition.

Note You need to log in before you can comment on or make changes to this bug.