Bug 199528 - The images block is not effective for the web site which load images from other url
The images block is not effective for the web site which load images from oth...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: Desktop
Depends On:
Blocks: 207526
  Show dependency treegraph
 
Reported: 2006-07-20 02:21 EDT by Nicole Dai
Modified: 2015-07-11 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 11:02:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicole Dai 2006-07-20 02:21:09 EDT
Description of problem:
In the Firefox Preferences,we can block images in some web sites by setting
Exceptions in 'Load Images'. But in the circumstance that the images in a web
site are loaded from another url, the images blocking will not be effective. For
example, we are going to block the images in www.yahoo.com, so we insert an
entry of www.yahoo.com with 'Block' status in Exceptions-Images. But the setting
is not effective because the images in www.yahoo.com are loaded from us.il.yimg.com.

Version-Release number of selected component (if applicable):
firefox-1.5.0.4-3

How reproducible:
Always

Steps to Reproduce:
1.In firefox, click menu 'Edit'-'Preferences'.
2.In 'Content' section, tick 'Load Images' and click 'Exceptions'.
3.Input www.yahoo.com in Address of web site and then click 'Block'.
4.Open www.yahoo.com in firefox to check if the images have been blocked.
  
Actual results:
The images in www.yahoo.com can still be loaded.

Expected results:


Additional info:
The problem exists in firefox-1.5.0.3-0.2.EL4 too.
Comment 1 Nicole Dai 2006-07-31 01:07:34 EDT
The bug was still found in firefox-1.5.0.5-7.
Comment 2 Martin Stransky 2006-12-05 11:02:09 EST
I can't imagine how we be able to fix it if it's a bug. Just imagine if you type
www.yahoo.com you can get a data from any site, you can be redirected to any
server/site...
Comment 3 Richard Jasmin 2015-07-11 16:09:56 EDT
I think the issue is being avoided here.It is true that content providers are en mass and provide lots of websites with content.HOW EV ER, if you BLOCK images for a domain, all requests should be blocked for that domain.Other people have figured out how to do this correctly like a light bulb switch.IT IS possible to do exactly what is being asked.

Note You need to log in before you can comment on or make changes to this bug.