Bug 199536 - wired IP is released too early
wired IP is released too early
Status: CLOSED DUPLICATE of bug 178276
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-20 04:20 EDT by Tomasz Torcz
Modified: 2008-02-12 09:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 09:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2006-07-20 04:20:40 EDT
Description of problem:
When switching from wired to wireless by clicking in networks list in applet,
NM first takes down IP address from wired interface, then tries to connect
to wifi. So there is a window of time when computer has no IP address
and no connectivity thus. This is fatal when user's home directory
is mounted by NFS. When wifi network need authentication, NM-applet window
with quiestion appears and some gconf action (reading or writing) is
performed. As NFS mount is unavailable (remember, no IP address), window
freezes. Also, X11 dislikes disappering IP addresses, as authorisation
is somehow based on them.


How reproducible:
Always.

Steps to Reproduce:
1. Log on as user with home on NFS mount. NFS server should be accessible
by wired and wireless networks.
2. Change to unknown wifi networks requiring authorisation.
3. (NM removes IP address from wired interface and tries to authorise
   and obtain address from wifi network)
  
Actual results:
Window displayed by NM freezes.

Expected results:
NM should remove IP address from wired interface AFTER it successfully
obtained connectivity (including IP address) from wireless network.

Additional info:
Workaround when nm-applet window freezes:
switch to console, login as root, restore wired interface IP address,
switch back to X, enter credentials to connect to wifi network,
let NM-applet remember those; after succesful connect switch
to console and remove IP address from wired interface
Comment 1 Orion Poplawski 2007-08-22 11:34:13 EDT
I see this issue with the latest rawhide too.
Comment 2 Tomislav Vujec 2007-10-05 02:01:18 EDT
I would hope that this would be possible with new multiple device support,
however, the nature of NFS is such that it can't really take an advantage of NM
as designed.

NM is best for gracefully handling use cases outside of its control (random
pull-out of the network cable, moving outside of APs range, etc.) However, for
this to work, application/service needs to play nice, and be ready to lose
network at any point in time. Many do so quite well already, from evolution to
cupsd. NFS is quite bad in that area (justifiably so, one might argue), and NFS
mounted home is the case where you wish you can somehow lock the cable to the
socket. However, I would argue that pushing NM in that direction, to require
explicit signaling before removing network device (which I see as the real
solution to your problem, once the reported behavior is fixed) would be wrong
for many other cases. However, a non-default option for that might suffice.
Comment 3 Diego Escalante Urrelo 2007-10-06 17:31:08 EDT
In case you care, there's a bug in b.g.o too:
http://bugzilla.gnome.org/show_bug.cgi?id=384971
Comment 4 Tomasz Torcz 2007-10-31 10:55:35 EDT
ad #2
In this case the same NFS server is accessible by wired and by wifi. 
Comment 5 Dan Williams 2008-02-12 09:09:24 EST

*** This bug has been marked as a duplicate of 178276 ***

Note You need to log in before you can comment on or make changes to this bug.