Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When we disable all the services and enable them back using foreman-maintain the foreman.service does not get enabled. Even after satellite reboot the service is still disabled and UI is not accessible with below error:
~~~~~~~~~~~~~~~~~~~~~~~~
Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
~~~~~~~~~~~~~~~~~~~~~~~~
Version-Release number of selected component (if applicable):
6.9
How reproducible:
100%
Steps to Reproduce:
1. foreman-maintain service stop
2. foreman-maintain service disable
3. foreman-maintain service enable
4. reboot
Actual results:
- When we enable the services the symlink for foreman.service does not get created.
- After reboot the foreman.service is in the failed state
~~~~~~~~~~~~~~~~~~
# systemctl status foreman.service
● foreman.service - Foreman
Loaded: loaded (/usr/lib/systemd/system/foreman.service; disabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/foreman.service.d
└─installer.conf
Active: inactive (dead)
Docs: https://theforeman.org
~~~~~~~~~~~~~~~~~~
- Satellite UI is not accessible with the below error:
~~~~~~~~~~~~~~~~~~
Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
~~~~~~~~~~~~~~~~~~
Expected results:
- After "foreman-maintain service enable" symlink for foreman.service should get created.
- After rebooting of satellite all services should be up and running and UI should be accssible.
Additional info:
- After restarting the foreman.service everything was fine in Satellite 6.9.
- Instead of reboot if we do 'satellite-maintain service restart' then we do not face any issues and all services are running without any error.
- If we perform similar test on Satellite 6.8, after reboot the foreman.service was disabled and not started. Along with that many services were just down.
~~~~~~~~~~~~~~~~~~~~
Some services are not running (rh-mongodb34-mongod, pulp_celerybeat, pulp_resource_manager, pulp_streamer)
--------------------------------------------------------------------------------
Scenario [Status Services] failed.
~~~~~~~~~~~~~~~~~~~~
- Though the UI was accessible in Satellite 6.8.
Verified on 6.14 snap 4
satellite-maintain service enable is correctly enabling the foreman service, even after reboot
Steps:
1. foreman-maintain service stop
2. foreman-maintain service disable
3. foreman-maintain service enable
4. reboot
Results:
If you run `# systemctl status foreman.service` right on boot you will get:
● foreman.service - Foreman
Loaded: loaded (/usr/lib/systemd/system/foreman.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/foreman.service.d
└─installer.conf
Active: activating (start) since Wed 2023-06-21 12:16:05 EDT; 9s ago
Docs: https://theforeman.org
Main PID: 896 (rails)
Tasks: 1 (limit: 151972)
Memory: 209.3M
CGroup: /system.slice/foreman.service
└─896 /usr/bin/ruby /usr/share/foreman/bin/rails server --environment production
After a few moments it will say `active (running)` and `foreman-maintain service status --brief --only foreman.service` will work correctly. During this restart period, `foreman-maintain service status` will fail.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (Important: Satellite 6.14 security and bug fix update), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2023:6818
Description of problem: When we disable all the services and enable them back using foreman-maintain the foreman.service does not get enabled. Even after satellite reboot the service is still disabled and UI is not accessible with below error: ~~~~~~~~~~~~~~~~~~~~~~~~ Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. ~~~~~~~~~~~~~~~~~~~~~~~~ Version-Release number of selected component (if applicable): 6.9 How reproducible: 100% Steps to Reproduce: 1. foreman-maintain service stop 2. foreman-maintain service disable 3. foreman-maintain service enable 4. reboot Actual results: - When we enable the services the symlink for foreman.service does not get created. - After reboot the foreman.service is in the failed state ~~~~~~~~~~~~~~~~~~ # systemctl status foreman.service ● foreman.service - Foreman Loaded: loaded (/usr/lib/systemd/system/foreman.service; disabled; vendor preset: disabled) Drop-In: /etc/systemd/system/foreman.service.d └─installer.conf Active: inactive (dead) Docs: https://theforeman.org ~~~~~~~~~~~~~~~~~~ - Satellite UI is not accessible with the below error: ~~~~~~~~~~~~~~~~~~ Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. ~~~~~~~~~~~~~~~~~~ Expected results: - After "foreman-maintain service enable" symlink for foreman.service should get created. - After rebooting of satellite all services should be up and running and UI should be accssible. Additional info: - After restarting the foreman.service everything was fine in Satellite 6.9. - Instead of reboot if we do 'satellite-maintain service restart' then we do not face any issues and all services are running without any error. - If we perform similar test on Satellite 6.8, after reboot the foreman.service was disabled and not started. Along with that many services were just down. ~~~~~~~~~~~~~~~~~~~~ Some services are not running (rh-mongodb34-mongod, pulp_celerybeat, pulp_resource_manager, pulp_streamer) -------------------------------------------------------------------------------- Scenario [Status Services] failed. ~~~~~~~~~~~~~~~~~~~~ - Though the UI was accessible in Satellite 6.8.