Bug 199593 - hald refuses to start
hald refuses to start
Status: CLOSED DUPLICATE of bug 199617
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-20 13:03 EDT by Michal Jaegermann
Modified: 2013-03-13 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 16:37:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-07-20 13:03:11 EDT
Description of problem:

After an update to hal-0.5.7-13 hald consistently refuses to start.
Consequently none of a desktop is running (or this is caused by
a new dbus package although dbus-daemon process is there?).

A tail of 'strace hald' shows the following:

.....
rt_sigaction(SIGCHLD, {0x40cab0, [CHLD], SA_RESTORER|SA_RESTART, 0x3c48a331a0},
{SIG_DFL}, 8) = 0
select(4, [3], NULL, [3], {250, 0})     = ? ERESTARTNOHAND (To be restarted)
--- SIGCHLD (Child exited) @ 0 (0) ---
rt_sigreturn(0x11)                      = -1 EINTR (Interrupted system call)
exit_group(1)                           = ?
Process 3824 detached

There were no problems before the last update and I simply do not
know if this is only x86_64 problem or other architectures are affected
as well.

Version-Release number of selected component (if applicable):
hal-0.5.7-13

How reproducible:
always
Comment 1 Michal Jaegermann 2006-07-20 15:07:08 EDT
With few "debuginfo" packages loaded a run of hald under gdb with
--daemon=no gets the following:

16810: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 1727 function dbus_connection_ref

Program received signal SIGABRT, Aborted.
0x0000003c48a33145 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003c48a33145 in raise () from /lib64/libc.so.6
#1  0x0000003c48a34a90 in abort () from /lib64/libc.so.6
#2  0x00002aaaaad2ccc5 in _dbus_abort () at dbus-sysdeps.c:89
#3  0x00002aaaaad1a377 in _dbus_real_assert (condition=<value optimized out>,
    condition_text=0x2aaaaad2ff38 "!(connection)->have_connection_lock",
    file=0x2aaaaad2f9de "dbus-connection.c", line=1727,
    func=0x2aaaaad31c30 "dbus_connection_ref") at dbus-internals.c:477
#4  0x00002aaaaaceeb9a in dbus_connection_ref (connection=0x6444c0)
    at dbus-connection.c:1727
#5  0x00002aaaaad0c51c in _dbus_pending_call_new (connection=0x6444c0,
    timeout_milliseconds=<value optimized out>,
    timeout_handler=0x2aaaaacf61c0 <reply_handler_timeout>)
    at dbus-pending-call.c:122
#6  0x00002aaaaacf5bd8 in dbus_connection_send_with_reply (
    connection=0x6444c0, message=0x671c20, pending_return=0x7fff27d9ff88,
    timeout_milliseconds=2147483647) at dbus-connection.c:2396
#7  0x000000000040762d in hald_runner_run_method (device=0x647410,
    command_line=0x429353 "hald-probe-smbios", extra_env=0x0,
    input=0x427878 "", error_on_stderr=0, timeout=10000,
    cb=0x414600 <computer_probing_pcbios_helper_done>, data1=0x0, data2=0x0)
    at hald_runner.c:357
#8  0x0000000000407777 in hald_runner_run (device=0x41aa,
    command_line=0x41aa <Address 0x41aa out of bounds>, extra_env=0x6,
    timeout=1219574880, cb=<value optimized out>, data1=<value optimized out>,
    data2=0x0) at hald_runner.c:384
#9  0x0000000000414421 in osspec_probe () at osspec.c:541
#10 0x000000000040d1da in main (argc=<value optimized out>,
    argv=0x7fff27da0608) at hald.c:576
#11 0x0000003c48a20aa4 in __libc_start_main () from /lib64/libc.so.6
#12 0x00000000004055e9 in _start ()

which looks related to backtraces from a bug #199596.  Smells like
something is tripping new 'dbus'.
Comment 2 John (J5) Palmieri 2006-07-20 16:37:08 EDT

*** This bug has been marked as a duplicate of 199617 ***

Note You need to log in before you can comment on or make changes to this bug.