Bug 199603 - kded_mediamanager crash with dbus-0.90
kded_mediamanager crash with dbus-0.90
Status: CLOSED DUPLICATE of bug 199617
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-20 14:18 EDT by Ngo Than
Modified: 2013-03-13 00:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 16:35:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2006-07-20 14:18:04 EDT
Description of problem:

kded_mediamanager crashes with dbus-0.90. It worked with 0.61 without any 
problem.

Version-Release number of selected component (if applicable):

kdebase-3.5.3-14

How reproducible:
login into KDE and you will see the crash. KDE is useless ATM
i attache the backstrace of the crash.

5  0x0000003f0ba33145 in raise () from /lib64/libc.so.6
#6  0x0000003f0ba34a90 in abort () from /lib64/libc.so.6
#7  0x00002aaab1bcacc5 in dbus_malloc () from /lib64/libdbus-1.so.3
#8  0x00002aaab1bb8377 in dbus_watch_set_data () from /lib64/libdbus-1.so.3
#9  0x00002aaab1b8cb9a in dbus_connection_ref () from /lib64/libdbus-1.so.3
#10 0x00002aaab1baa51c in dbus_pending_call_ref () from /lib64/libdbus-1.so.3
#11 0x00002aaab1b93bd8 in dbus_connection_send_with_reply ()
   from /lib64/libdbus-1.so.3
#12 0x00002aaab1b94068 in dbus_connection_send_with_reply_and_block ()
   from /lib64/libdbus-1.so.3
#13 0x00002aaab1b8bb61 in dbus_bus_register () from /lib64/libdbus-1.so.3
#14 0x00002aaab153ca54 in HALBackend::InitHal ()
   from /usr/lib64/kde3/kded_mediamanager.so
#15 0x00002aaab151e322 in MediaManager::loadBackends ()
   from /usr/lib64/kde3/kded_mediamanager.so
#16 0x00002aaab151e67c in MediaManager::qt_invoke ()
   from /usr/lib64/kde3/kded_mediamanager.so
#17 0x00002aaaabd019d9 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#18 0x00002aaaac0372e4 in QSignal::signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#19 0x00002aaaabd1cdc5 in QSignal::activate ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#20 0x00002aaaabd24d78 in QSingleShotTimer::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#21 0x00002aaaabca0db5 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#22 0x00002aaaabca2294 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#23 0x00002aaaab489768 in KApplication::notify ()
   from /usr/lib64/libkdecore.so.4
Comment 1 John (J5) Palmieri 2006-07-20 16:35:59 EDT

*** This bug has been marked as a duplicate of 199617 ***

Note You need to log in before you can comment on or make changes to this bug.