Bug 199605 - selinux labeling failures
Summary: selinux labeling failures
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Test3Blocker
TreeView+ depends on / blocked
 
Reported: 2006-07-20 18:39 UTC by Jesse Keating
Modified: 2013-01-10 02:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 19:25:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2006-07-20 18:39:30 UTC
/etc/sysconfig/network, /etc/hosts, and
/etc/sysconfig/network-scripts/ifcfg-eth0 are all getting the wrong label (file_t).

Also the homerestorecon thing isn't working right for the images, /home and
/root have the wrong context.

This was from a tree generated 7/19/2006

Comment 1 Jeremy Katz 2006-07-20 19:31:27 UTC
The network stuff is because we now set up the network config earlier, should be
fixed in CVS

For /home and /root, have a pointer to the tree (and especially the buildinstall
log) that you're seeing this with?  The files in rawhide-20060720 look right to me

Comment 2 Jesse Keating 2006-07-20 20:03:10 UTC
/mnt/redhat/rel-eng/FC5.90.1-re20060719.0/logs/i386-logs/buildinstall.log

Comment 3 Jeremy Katz 2006-07-21 01:29:38 UTC
Hrmm, everything looks sane to me in stage2.img --
/etc/selinux/targeted/contexts/files/file_contexts.homedirs is there and looks sane.

Dan -- any thoughts on other things which would break this?

Comment 4 Daniel Walsh 2006-07-26 19:25:32 UTC
This was caused by a bug in rpm spec file which has been fixed.


Note You need to log in before you can comment on or make changes to this bug.