Bug 199639 - NIC unable to find a DHCP address during install, even though PXE finds an address
NIC unable to find a DHCP address during install, even though PXE finds an ad...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
: Desktop
Depends On:
Blocks: 183415
  Show dependency treegraph
 
Reported: 2006-07-20 18:01 EDT by Suzanne Hillman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 15:30:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2006-07-20 18:01:32 EDT
Description of problem:
NIC unable to find a DHCP address during install, even though PXE finds an
address. This makes it inordinately difficult to install on this machine in
order to do testing.

It's an Acer Aspire 3002LCi, and its NIC is SiS900 (and the correct module is
being loaded, according to the log)

May be kernel, not anaconda; not sure.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.54-1
or possibly
kernel-2.6.17-1.2358.fc6

How reproducible:
Seems to be always.

Steps to Reproduce:
1. Either via PXE or boot disk, try to start an install
2. When it gets to the point of DHCP, ask it to get an address.
  
Actual results:
It will fail, even if you used PXE at the start, which makes no sense at all.

Expected results:
Should work. I thought it used to work in FC5, but am unsure.
Comment 1 Jeremy Katz 2006-07-20 18:16:27 EDT
That's a really really old anaconda -- please try with a newer tree
Comment 2 Suzanne Hillman 2006-07-21 16:17:23 EDT
Hmm. Actually, I do not know what version of either anaconda or kernel, as I was
unable to get a prompt while at the DHCP screen via PXE. It was whatever was
available via PXE yesterday.

(I was not aware that the latest link on curly was not the same as the rawhide
link in PXE, thus the problem)
Comment 3 David Cantrell 2006-08-03 14:19:42 EDT
Is this working with current RHEL5 or rawhide nightly builds?
Comment 4 Suzanne Hillman 2006-08-03 15:30:56 EDT
Looks to be working with current RHEL5, thank you!

Note You need to log in before you can comment on or make changes to this bug.