Bug 199684 - Forward port 2.6.17 ia64 xen to 2.6.18
Summary: Forward port 2.6.17 ia64 xen to 2.6.18
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: ia64 Linux
high
medium
Target Milestone: ---
Assignee: Prarit Bhargava
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 200991 (view as bug list)
Depends On:
Blocks: 184858 199683 200124
TreeView+ depends on / blocked
 
Reported: 2006-07-21 12:46 UTC by Prarit Bhargava
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 12:01:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that compiles xen and non-xen kernels on latest ia64 rawhide (35.91 KB, patch)
2006-07-25 14:02 UTC, Prarit Bhargava
no flags Details | Diff
Patch that compiles xen and non-xen kernels on latest ia64 rawhide (39.59 KB, patch)
2006-07-25 19:01 UTC, Prarit Bhargava
no flags Details | Diff
ia64 patches from http://free.linux.hp.com/~agriffis/linux-2.6-xen-fedora-ia64 (27.04 KB, patch)
2006-07-27 16:53 UTC, Aron Griffis
no flags Details | Diff

Description Prarit Bhargava 2006-07-21 12:46:19 UTC
We need to forward port the 2.6.17 ia64 xen code to 2.6.18.


+++ This bug was initially created as a clone of Bug #199683 +++

With the submission of the 2.6.17 xen ia64 code, we should be able to enable xen
on ia64 kernels.

-- Additional comment from prarit@redhat.com on 2006-07-21 08:43 EST --
Created an attachment (id=132800)
patch to enable xen ia64 kernel

Comment 1 Prarit Bhargava 2006-07-25 14:02:38 UTC
Created attachment 132985 [details]
Patch that compiles xen and non-xen kernels on latest ia64 rawhide

Comment 2 Prarit Bhargava 2006-07-25 14:24:15 UTC
With the above patch, non-xen kernels seem fine.  I'm running lmbench, lsb, and
ltp tests now.

Xen kernels, however, do not boot. :(

P.

Comment 3 Alex Williamson 2006-07-25 15:16:37 UTC
ia64 libaio build fix:
http://xenbits.xensource.com/xen-unstable.hg?cs=3352b5dc6a7c

ia64 blktap build fix:
http://xenbits.xensource.com/xen-unstable.hg?cs=43bd4b01df9f

disable blktap in ia64 buildconfig:
http://xenbits.xensource.com/xen-unstable.hg?cs=7bf0d46e369a

Comment 4 Prarit Bhargava 2006-07-25 18:09:19 UTC
>ia64 libaio build fix:
http://xenbits.xensource.com/xen-unstable.hg?cs=3352b5dc6a7c

is already in fedora.


>ia64 blktap build fix:
http://xenbits.xensource.com/xen-unstable.hg?cs=43bd4b01df9f

should be pushed in it own BZ (I'll open one shortly for this).

>disable blktap in ia64 buildconfig:
http://xenbits.xensource.com/xen-unstable.hg?cs=7bf0d46e369a

Applied and will be in next patch.


Comment 5 Prarit Bhargava 2006-07-25 19:01:21 UTC
Created attachment 133010 [details]
Patch that compiles xen and non-xen kernels on latest ia64 rawhide

New patch.

Comment 6 Aron Griffis 2006-07-27 16:53:50 UTC
Created attachment 133170 [details]
ia64 patches from http://free.linux.hp.com/~agriffis/linux-2.6-xen-fedora-ia64

I don't have perms to obsolete Prarit's attachment

Comment 8 Aron Griffis 2006-07-29 02:57:40 UTC
Juan applied kernel mods, we're still waiting on spec mods to be applied

Comment 9 Jeremy Katz 2006-08-02 01:36:26 UTC
*** Bug 200991 has been marked as a duplicate of this bug. ***

Comment 10 Aron Griffis 2006-08-17 02:14:08 UTC
Since the xen kernel has been in the ia64 builds for the past couple weeks, I
think this bug can be closed...

Comment 11 Jarod Wilson 2006-08-17 14:06:31 UTC
Is there another bug tracking progress toward actually being able to boot the
xen kernels on ia64?

Comment 12 Aron Griffis 2006-08-17 14:32:11 UTC
(In reply to comment #11)
> Is there another bug tracking progress toward actually being able to boot the
> xen kernels on ia64?

xen/ia64 boots on Fedora now.  There are some individual bugs that I intend to
file today, plus a meta-bug to track them all.  I'll update this bug with a
pointer when that happens.

Comment 13 Jarod Wilson 2006-08-17 14:41:56 UTC
Ah, okay. PM and QE would like a RHEL5-specific bug to track this as well. I was
about to clone this one for that purpose, and can still do so if you like, but
if you've already got one lined up, I can wait.

Comment 14 Aron Griffis 2006-08-17 15:47:15 UTC
Jarod, see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=xen-ia64

I'll be adding bugs to that as I file them.  Right now only the most critical
one is represented.


Note You need to log in before you can comment on or make changes to this bug.