Bug 199692 - Resume fails when using compiz
Resume fails when using compiz
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-07-21 09:22 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-25 23:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-07-21 09:22:03 EDT
(Feel free to remove yourself from CC if you don't think it's your code. :) )

Resume from suspend hangs when I'm using compiz as the WM when I suspend. It
returns to the text mode (using radeonfb), but then the display locks. It
appears as if the computer is still running, as hitting the power button
starts a graceful shutdown.

Resume when using metacity works OK.

HW notes:
Thinkpad T40p
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 [Mobility
FireGL 9000] (rev 02)

Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2416.fc6
xorg-x11-server-Xorg-1.1.1-6.fc6
xorg-x11-drv-ati-6.6.1-4.1
compiz-0.0.13.fedora1-3
pm-utils-0.19-2

How reproducible:

Every time.

Steps to Reproduce:
1. start-compiz
2. pm-suspend
3. <resume>
Comment 1 Pete Graner 2006-07-21 09:28:02 EDT
I'm seeing the same exact behavior, to include package versions as Bill.

Noticed after 18 July's rawhide update. At that time I thought it was a kernel
thing and waited to update till after the dbus bits were worked out.

Still doing it. I tried with out compiz and used metacity and suspend resume
works as expected.
Comment 2 Bojan Smojver 2006-08-23 16:03:39 EDT
Same here for Dell Inspiron 6400 (Intel 945 graphics). Works fine with metacity.

Packages:

kernel-2.6.17-1.2583.fc6
xorg-x11-server-Xorg-1.1.1-26.fc6
xorg-x11-drv-i810-1.6.5-4.fc6
compiz-0.0.13-0.16.20060817git.fc6
pm-utils-0.19-3

Note that 915resolution is required to run on resume on this machine in order to
get 1680 x 1050. This is done via /etc/pm/hooks/99resolution, which works fine
for metacity:

-----------------------------------
#!/bin/sh

case "$1" in
        thaw|resume)
                { /sbin/service 915resolution start ; } 2>/dev/null
                ;;
        *)
                ;;
esac

exit $?
-----------------------------------
Comment 3 Kristian Høgsberg 2006-08-25 01:30:01 EDT
Please give xorg-x11-server-Xorg-1.1.1-29.fc6 a try.  This build has a fix for
vt switching which should also fix the suspend/resume problems.

Bojan: try using the "intel" driver instead of the "i810" driver - that driver
has the new modesetting code which should be able to set any mode natively.
Comment 4 Bojan Smojver 2006-08-25 02:00:47 EDT
OK, I'll give new Xorg server a go.

BTW, modesetting doesn't work on this Dell machine. Tried it a few times, but no
luck (actually, that's documented in the modesetting Intel driver bug, by me and
others).
Comment 5 Bojan Smojver 2006-08-25 08:08:02 EDT
Yeah, .29 resumes fine with compiz.
Comment 6 Bill Nottingham 2006-08-25 23:33:00 EDT
Works for me with .30.

Note You need to log in before you can comment on or make changes to this bug.