Bug 1996952 - The reference of deprecated Background download policy is still present in global settings of Red Hat Satellite 6.10
Summary: The reference of deprecated Background download policy is still present in gl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.10.0
Hardware: All
OS: Linux
unspecified
medium vote
Target Milestone: 6.10.0
Assignee: Ian Ballou
QA Contact: sganar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-24 05:39 UTC by Sayan Das
Modified: 2021-11-16 14:13 UTC (History)
6 users (show)

Fixed In Version: tfm-rubygem-katello-4.1.1.25-1,tfm-rubygem-katello-4.1.1.28-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-16 14:13:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 33468 0 None None None 2021-09-10 18:48:34 UTC
Red Hat Product Errata RHSA-2021:4702 0 None None None 2021-11-16 14:13:35 UTC

Description Sayan Das 2021-08-24 05:39:21 UTC
Description of problem:

The background download policy should have been removed from all possible locations but It's still listed for the "Download Policy" related settings.

Version-Release number of selected component (if applicable):

Satellite 6.10 [ latest snap ]

How reproducible:
Always

Steps to Reproduce:
1. Install a Satellite 6.10
2. Go to Administer --> Settings --> Content and look for "Default Custom Repository download policy", "Default Red Hat Repository download policy" and "Default Smart Proxy download policy"


Actual results:

For each of those settings, 

* DESCRIPTION shows the availability of the Background download policy.

* If we click on the value of any of those three options and then click on the Drop-Down , "background (deprecated)" is still listed as a valid option.


Expected results:

Background policy should not be there as an acceptable value to select and no DESCRIPTION should contain the reference of the same.


Additional info:

# hammer --output yaml settings list --search "policy"

---
- Name: default_download_policy
  Full name: Default Custom Repository download policy
  Value: immediate
  Description: Default download policy for custom repositories (either 'immediate',
    'on_demand', or 'background')

- Name: default_redhat_download_policy
  Full name: Default Red Hat Repository download policy
  Value: on_demand
  Description: Default download policy for enabled Red Hat repositories (either 'immediate',
    'on_demand', or 'background')

- Name: default_proxy_download_policy
  Full name: Default Smart Proxy download policy
  Value: on_demand
  Description: Default download policy for Smart Proxy syncs (either 'inherit', immediate',
    'on_demand', or 'background')

Comment 1 Justin Sherrill 2021-09-23 14:40:25 UTC
Connecting redmine issue https://projects.theforeman.org/issues/33468 from this bug

Comment 2 Brad Buckingham 2021-09-28 15:28:16 UTC
Moving to POST as upstream PR is merged.

Comment 7 sganar 2021-10-13 07:54:08 UTC
Verified.

Tested on Satellite 6.10.0 Snap 22.0

Steps followed: 
1. Install a Satellite 6.10
2. Go to Administer --> Settings --> Content and look for "Default Custom Repository download policy", "Default Red Hat Repository download policy" and "Default Smart Proxy download policy"

Observation: 

"background (deprecated)" is not listed as an option as expected.

Comment 10 errata-xmlrpc 2021-11-16 14:13:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: Satellite 6.10 Release), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:4702


Note You need to log in before you can comment on or make changes to this bug.