Bug 1997268 - test gtest-io-io-test-RIoUring always fail on rebuild
Summary: test gtest-io-io-test-RIoUring always fail on rebuild
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: root
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-08-24 19:09 UTC by Tuomo Soini
Modified: 2021-09-05 20:15 UTC (History)
1 user (show)

Fixed In Version: root-6.24.04-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-05 20:15:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Tuomo Soini 2021-08-24 19:09:14 UTC
I tried to rebuild root-6.24.2-1.el8 on mock (systemd-nspawn, tmpfs) and this one test always fails:

150/1107 Test #109: gtest-io-io-test-RIoUring ...........................................***Failed 0.58 sec
Running main() from gtest_main.cc
Note: Google Test filter = -RCsvDS.Remote:RRawFile.Remote:RSqliteDS.Davix

I have rebuilt root package for years and this was first time there is consistent test failure (I tried rebuild three times).

Comment 1 Tuomo Soini 2021-08-26 13:56:42 UTC
Ok. Problem is that root package has enabled uring support. That can't be done for epel8 because rhel8 kernel doesn't have support.

https://github.com/root-project/root/issues/8895

Build only succeeds because epel buildsystem runs on fedora so on kernel which does support uring.

Fix is to disable uring for epel8.

I suggest removing uring for all rhel versions because I don't know if uring is supported by rhel9.

Here is minimalistic change:

diff --git a/root.spec b/root.spec
index 26aeb7a..d71a9af 100644
--- a/root.spec
+++ b/root.spec
@@ -233,7 +233,7 @@ BuildRequires:      cmake-data >= 3.18.3-1
 BuildRequires: openblas-devel
 %endif
 BuildRequires: json-devel
-%if %{?fedora}%{!?fedora:0} || %{?rhel}%{!?rhel:0} >= 8
+%if %{?fedora}%{!?fedora:0}
 BuildRequires: liburing-devel
 %endif
 %if %{?fedora}%{!?fedora:0} || %{?rhel}%{!?rhel:0} >= 8
@@ -2109,7 +2109,7 @@ LDFLAGS="-Wl,--as-needed %{?__global_ldflags}"
        -Dtmva-pymva:BOOL=ON \
        -Dtmva-rmva:BOOL=ON \
        -Dunuran:BOOL=ON \
-%if %{?fedora}%{!?fedora:0} || %{?rhel}%{!?rhel:0} >= 8
+%if %{?fedora}%{!?fedora:0}
        -During:BOOL=ON \
 %else
        -During:BOOL=OFF \

Comment 2 Fedora Update System 2021-08-29 04:17:47 UTC
FEDORA-EPEL-2021-817370d4a8 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-817370d4a8

Comment 3 Mattias Ellert 2021-08-29 04:27:59 UTC
It's odd that RHEL 8 has a liburing package when the RHEL 8 kernel does not support its usage...

Comment 4 Fedora Update System 2021-08-29 18:43:37 UTC
FEDORA-EPEL-2021-817370d4a8 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-817370d4a8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-09-05 20:15:23 UTC
FEDORA-EPEL-2021-817370d4a8 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.