Bug 199739 - Version bump needed for hamlib
Version bump needed for hamlib
Product: Fedora
Classification: Fedora
Component: hamlib (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-07-21 13:55 EDT by Robert 'Bob' Jensen
Modified: 2015-04-22 16:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-30 15:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Spec File (8.81 KB, application/octet-stream)
2006-09-28 19:11 EDT, Robert 'Bob' Jensen
no flags Details
SRC RPM (1.35 MB, application/octet-stream)
2006-09-28 19:12 EDT, Robert 'Bob' Jensen
no flags Details
Spec File (8.82 KB, application/octet-stream)
2006-09-28 20:02 EDT, Robert 'Bob' Jensen
no flags Details

  None (edit)
Description Robert 'Bob' Jensen 2006-07-21 13:55:31 EDT
Description of problem:
Version bump needed

Version-Release number of selected component (if applicable):

Expected results:
Version 1.2.5

Additional info:
Version 1.2.5 was released 2006-02-26
Comment 1 Robert 'Bob' Jensen 2006-09-28 19:11:21 EDT
Created attachment 137349 [details]
Spec File

Here is the spec file I created, I am sure it is not perfect.
Comment 2 Robert 'Bob' Jensen 2006-09-28 19:12:57 EDT
Created attachment 137350 [details]

Here is the src.rpm I created
Comment 3 Robert 'Bob' Jensen 2006-09-28 19:14:10 EDT
hopefully the attachments will help get this rolling.
Comment 4 Robert 'Bob' Jensen 2006-09-28 20:02:50 EDT
Created attachment 137351 [details]
Spec File
Comment 5 Kevin Fenzi 2006-09-28 23:10:23 EDT
Just a few comments to help moving this along... 

rpmlint is giving me a bunch of: 

E: hamlib invalid-soname /usr/lib/hamlib-aor.so hamlib-aor.so
E: hamlib invalid-soname /usr/lib/hamlib-kenwood.so hamlib-kenwood.so

In the build.log I see:
checking for libxml - version >= 2.0.0... no
*** The xml2-config script installed by LIBXML could not be found
*** If libxml was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XML2_CONFIG environment variable to the
*** full path to xml2-config.

perhaps you need a 'BuildRequires libxml2-devel' ?

checking for Tcl configuration... configure: WARNING: Can't find Tcl 
configuration definitions
checking whether to build tcl binding and demo... no

Perhaps a 'BuildRequires: tcl-devel' ?

Some more possible missing BuildRequires: 

checking for PyArg_Parse... no
checking whether to build gnuradio backend... no
checking whether to build USRP backend... no
checking whether to build microtune backend... yes
checking for libusb >= 0.1... configure: WARNING: libusb pkg-config not found, 
USB backends will be disabled

Not sure how many of those exist in extras already, but if so, they should be 
added as buildrequires. 

Some other general tips: 

- You should just provide a link to the .spec and one to the latest .src.rpm 
here, it's easier than attachments (IMHO). 
- You should remember to increase the release and add a changelog entry for 
every time you update. This helps note which things are fixed in the latest 
package and so forth. 
Comment 6 Dennis Gilmore 2006-09-30 15:46:07 EDT
1.2.5  has been built for FC-4 FC-5 and rawhide
I added some BR's  to clean things up a little  and removed the 
Requires /bin/sh 

Note You need to log in before you can comment on or make changes to this bug.