Bug 199743 - /bin/ksh should be the *real* (open-source) Korn Shell
/bin/ksh should be the *real* (open-source) Korn Shell
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: RHEL Product and Program Management
Daniel Riek
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-21 14:04 EDT by Kurt Lloyd
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 04:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Lloyd 2006-07-21 14:04:17 EDT
/bin/ksh has been "PDKSH" for historical reasons,
since the "real" Korn Shell was closed-source long ago.
The "real" Korn Shell is not only far superior,
but has been open-source for quite some time now,
and is still under active development, unlike PDKSH.

/bin/ksh should come from:

http://www.kornshell.com/

Mac OS X has it right, BTW.
Comment 2 Daniel Riek 2006-07-22 09:43:38 EDT
The ksh package is on the LACD aka "Extras" and can be installed as an
alternative to pdksh. Please explain why this is not sufficient.
Comment 3 Kurt Lloyd 2006-07-22 22:53:51 EDT
The reason is that Linux systems should be able to have this shell in its proper
location as the default.  Aside from being a great interactive shell, the "real"
Korn Shell is probably the very best shell script interpreter for shell scripts
that use #! in their first line.  A great deal of effort was put into it for
this purpose.  In such scripts, #!/bin/ksh is the standard, proper location for
it.  The default /bin/ksh should be the original, superior, and actively
supported version.
Comment 4 Daniel Riek 2006-07-23 16:26:02 EDT
I am sorry, but I am not sure I understand why it would not be acceptable to
install the ksh package from the LACD / Extras channel? That easily can be made
default in kickstart installations.

The pathnames in that package are default.

For RHEL5 we drop pdksh so only ksh will be there. There though is no way to
change that for already released versions of RHEL.
Comment 5 Kurt Lloyd 2006-07-23 22:49:25 EDT
If the "real" Korn Shell, i.e., the one from http://www.kornshell.com/ , will
indeed be /bin/ksh in default RHEL5 installations then this bug can be closed as
far as I am concerned.  Thank you.
Comment 6 Karsten Hopp 2006-08-01 04:51:47 EDT
Closing this report, based on comment #5

Note You need to log in before you can comment on or make changes to this bug.